Bug 217244 - archivers/lzmalib: remove port?
Summary: archivers/lzmalib: remove port?
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-20 07:01 UTC by eserte12
Modified: 2018-02-01 08:17 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eserte12 2017-02-20 07:01:52 UTC
lzmalib installs /usr/local/lib/liblzma.so which conflicts with the base system /usr/lib/liblzma.so. This can cause problems, see for example https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210626 and https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=209355

According to the research in these bug reports, the lzmalib port is needed only by archivers/p5-Compress-Raw-Lzma and databases/tokyocabinet. I just tried to build PMQS/Compress-Raw-Lzma-2.074.tar.gz directly from CPAN without the lzmalib port, and it worked (all tests passed), so it seems that at least p5-Compress-Raw-Lzma does not need the lzmalib port. Maybe the same is the case for tokyocabinet.

I think it would be good if the lzmalib port could be removed to reduce potential confusion.
Comment 1 Walter Schwarzenfeld freebsd_triage 2017-02-20 09:54:55 UTC
I noticed some other ports use lzmalib if it is installed (last seen 
with the libxslt port - blocked on my system recent memcached update -
following the move of libevent. Another time libreoffice don't stated
with a error message pointed to lzmalib). If lzmalib is removed, it is only needed to rebuild this port.
This problem should mentioned in /usr/ports/UPDATING (I think some 
other users will have same problems)
Comment 2 Walter Schwarzenfeld freebsd_triage 2017-02-24 20:56:07 UTC
And:_
pkg install qt5-webkit

New packages to be INSTALLED:
	qt5-webkit: 5.7.1
	lzmalib: 0.0.1_1

don't know why, there is no dependency.
Comment 3 Walter Schwarzenfeld freebsd_triage 2017-03-19 09:29:29 UTC
Forget my previous post. Pkg_libchk told me nothing, portmaster --check-depends told me 
nothing. Pkg check -d states some ports/packages missing liblzma.so.1 after I removed 
lzmalib. I had to recompile this ports. This fixed this issue.
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-02-01 08:17:04 UTC
pkg install qt5-webkit shows:
New packages to be INSTALLED:
	qt5-webkit: 5.212.0.a2_5 [FreeBSD]
	qt5-webchannel: 5.9.4 [FreeBSD]
	gstreamer1-plugins-core: 1.12 [FreeBSD]
	gstreamer1-plugins-pango: 1.12.3 [FreeBSD]
	gstreamer1-plugins-ugly: 1.12.3 [FreeBSD]
	gstreamer1-plugins-theora: 1.12.3 [FreeBSD]
	gstreamer1-plugins-resindvd: 1.12.3 [FreeBSD]
	gstreamer1-plugins-good: 1.12.3 [FreeBSD]
	gstreamer1-plugins-dvdread: 1.12.3 [FreeBSD]
	gstreamer1-plugins-dts: 1.12.3 [FreeBSD]
	gstreamer1-libav: 1.12.3_1 [FreeBSD]
	gstreamer1-plugins-png: 1.12.3 [FreeBSD]
	gstreamer1-plugins-vorbis: 1.12.3 [FreeBSD]
	gstreamer1-plugins-ogg: 1.12.3 [FreeBSD]
	gstreamer1-plugins-mpg123: 1.12.3 [FreeBSD]
	gstreamer1-plugins-a52dec: 1.12.3 [FreeBSD]
	qt5-location: 5.9.4 [FreeBSD]
	qt5-sensors: 5.9.4 [FreeBSD]

and
pkg info liblzma
pkg: No package(s) matching liblzma


Overcome by events, so I close here