Bug 217355 - emulators/qemu: add iSCSI option; add port net/libiscsi
Summary: emulators/qemu: add iSCSI option; add port net/libiscsi
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-25 16:22 UTC by Martin Birgmeier
Modified: 2020-06-06 12:14 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (bofh)


Attachments
patch to create net/libiscsi and to add ISCSI option to emulators/qemu-sbruno (3.13 KB, patch)
2017-02-25 16:22 UTC, Martin Birgmeier
no flags Details | Diff
Upgrade net/libiscsi to 1.19.0 (2.61 KB, patch)
2020-04-30 16:53 UTC, Martin Birgmeier
no flags Details | Diff
patch for emulators/qemu (1.22 KB, patch)
2020-04-30 17:27 UTC, Martin Birgmeier
no flags Details | Diff
correct the update to libiscsi-1.19.0 (plist was wrong) (2.61 KB, patch)
2020-05-01 09:29 UTC, Martin Birgmeier
no flags Details | Diff
Updated patch for libiscsi-1.19.0 (3.66 KB, patch)
2020-05-27 20:19 UTC, Martin Birgmeier
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2017-02-25 16:22:41 UTC
Created attachment 180289 [details]
patch to create net/libiscsi and to add ISCSI option to emulators/qemu-sbruno

I needed iSCSI in qemu-sbruno, so I added a new port net/libiscsi and an option ISCSI in qemu-sbruno.

The new port should be checked for errors first, I only tested it lightly on releng/11.0 amd64.

-- Martin
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-01-16 11:29:03 UTC
Maintainer feedback?
Comment 2 Yuri Pankov 2018-05-18 18:55:59 UTC
May be we could separate addition of libiscsi port from modifying the qemu-sbruno one and get this going forward? (I'm particularly interested in libiscsi itself.)
Comment 3 Sean Bruno freebsd_committer 2018-05-18 19:38:27 UTC
Oh hey.  I'm just curious why emulators/qemu isn't what you are using here.  Is there something missing in the current release?

qemu-sbruno is *really* just a port that exists to build the qemu-user-static binaries.
Comment 4 Martin Birgmeier 2020-04-30 16:53:11 UTC
Created attachment 213958 [details]
Upgrade net/libiscsi to 1.19.0
Comment 5 Sean Bruno freebsd_committer 2020-04-30 17:21:32 UTC
(In reply to Martin Birgmeier from comment #4)
Martin:

Oh hey.  I'm just curious why emulators/qemu isn't what you are using here.  Is there something missing in the current release?

qemu-sbruno is *really* just a port that exists to build the qemu-user-static binaries.
Comment 6 Martin Birgmeier 2020-04-30 17:27:18 UTC
Created attachment 213959 [details]
patch for emulators/qemu

You are right - here is the same patch for emulators/qemu.

-- Martin
Comment 7 Martin Birgmeier 2020-05-01 09:29:51 UTC
Created attachment 213975 [details]
correct the update to libiscsi-1.19.0 (plist was wrong)
Comment 8 Muhammad Moinur Rahman freebsd_committer 2020-05-03 22:27:51 UTC
(In reply to Martin Birgmeier from comment #6)
Hi,
I am working on qemu 5.x branch at this time. Please bear with me.
Comment 9 Martin Birgmeier 2020-05-04 11:44:36 UTC
Thank you for your work! - This is just a small addition, and I wanted to correct my erroneous submission, there is no pressure!

-- Martin
Comment 10 Muhammad Moinur Rahman freebsd_committer 2020-05-04 12:57:51 UTC
(In reply to Sean Bruno from comment #5)
Hi Sean .. Are you going to take care of libiscsi ? Or should I do it ?
Comment 11 Sean Bruno freebsd_committer 2020-05-04 13:13:10 UTC
(In reply to Muhammad Moinur Rahman from comment #10)
I will not be doing it.
Comment 12 Martin Birgmeier 2020-05-05 18:46:29 UTC
Hi Muhammad,

If it is too much effort let us just close this ticket - this is not that important. FreeBSD developers are overworked anyway.

Best regards, Martin
Comment 13 Muhammad Moinur Rahman freebsd_committer 2020-05-26 21:33:13 UTC
(In reply to Martin Birgmeier from comment #12)
Hi,
Noops. It's not too much effort. These are duties with the hats on. :B

But the problem is libiscsi do not build successfully on i386 hosts. Or is it meant only for i386 hosts. For logs please check the following:
http://pdr.bofh.network/data/latest-per-pkg/libiscsi/1.19.0/
Comment 14 Martin Birgmeier 2020-05-27 20:19:12 UTC
Created attachment 214933 [details]
Updated patch for libiscsi-1.19.0

I have updated the patch. Checked for compile on 12.1 i386 and amd64.

-- Martin
Comment 15 commit-hook freebsd_committer 2020-05-30 00:31:52 UTC
A commit references this bug:

Author: bofh
Date: Sat May 30 00:31:40 UTC 2020
New revision: 537021
URL: https://svnweb.freebsd.org/changeset/ports/537021

Log:
  [NEW] net/libiscsi: Client-side library to implement the iSCSI protocol

  Libiscsi is a client-side library to implement the iSCSI protocol
  that can be used to access the resources of an iSCSI target.

  The library is fully asynchronous with regards to iSCSI commands
  and SCSI tasks, but a synchronous layer is also provided for ease
  of use for simpler applications.

  WWW: https://github.com/sahlberg/libiscsi

  PR:		217355
  Submitted by:	d8zNeCFG@aon.at

Changes:
  head/net/Makefile
  head/net/libiscsi/
  head/net/libiscsi/Makefile
  head/net/libiscsi/distinfo
  head/net/libiscsi/files/
  head/net/libiscsi/files/patch-configure.ac
  head/net/libiscsi/files/patch-lib_login.c
  head/net/libiscsi/pkg-descr
  head/net/libiscsi/pkg-plist
Comment 16 commit-hook freebsd_committer 2020-06-06 10:02:41 UTC
A commit references this bug:

Author: bofh
Date: Sat Jun  6 10:02:12 UTC 2020
New revision: 538082
URL: https://svnweb.freebsd.org/changeset/ports/538082

Log:
  emulators/qemu: Add NCURSES option

  - Add ISCSI OPTION [1]

  PR:             246038 217355 [1]
  Submitted by:   cy d8zNeCFG@aon.at [1]

Changes:
  head/emulators/qemu/Makefile
Comment 17 Muhammad Moinur Rahman freebsd_committer 2020-06-06 10:11:33 UTC
Just to mention I haven't actually added it as DEFAULT option.
Comment 18 Martin Birgmeier 2020-06-06 12:14:33 UTC
Thank you!

Best regards, Martin