Bug 217355 - emulators/qemu-sbruno: add iSCSI option; add port net/libiscsi
Summary: emulators/qemu-sbruno: add iSCSI option; add port net/libiscsi
Status: In Progress
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sean Bruno
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-25 16:22 UTC by Martin Birgmeier
Modified: 2018-05-18 19:38 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (sbruno)


Attachments
patch to create net/libiscsi and to add ISCSI option to emulators/qemu-sbruno (3.13 KB, patch)
2017-02-25 16:22 UTC, Martin Birgmeier
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2017-02-25 16:22:41 UTC
Created attachment 180289 [details]
patch to create net/libiscsi and to add ISCSI option to emulators/qemu-sbruno

I needed iSCSI in qemu-sbruno, so I added a new port net/libiscsi and an option ISCSI in qemu-sbruno.

The new port should be checked for errors first, I only tested it lightly on releng/11.0 amd64.

-- Martin
Comment 1 w.schwarzenfeld freebsd_triage 2018-01-16 11:29:03 UTC
Maintainer feedback?
Comment 2 Yuri Pankov 2018-05-18 18:55:59 UTC
May be we could separate addition of libiscsi port from modifying the qemu-sbruno one and get this going forward? (I'm particularly interested in libiscsi itself.)
Comment 3 Sean Bruno freebsd_committer 2018-05-18 19:38:27 UTC
Oh hey.  I'm just curious why emulators/qemu isn't what you are using here.  Is there something missing in the current release?

qemu-sbruno is *really* just a port that exists to build the qemu-user-static binaries.