Bug 217384 - lang/ruby23: dependency version mismatch
Summary: lang/ruby23: dependency version mismatch
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-27 02:26 UTC by Yunchih Chen
Modified: 2017-02-27 06:38 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yunchih Chen 2017-02-27 02:26:35 UTC
Revision 434270[1] breaks my ruby23 build.
The current version of doxygen is 1.8.12,2, so the statement will fail:

doxygen>1.8.12,2:devel/doxygen

Proposed patch:

Index: lang/ruby23/Makefile
===================================================================
--- lang/ruby23/Makefile        (revision 434884)
+++ lang/ruby23/Makefile        (working copy)
@@ -55,7 +55,7 @@
 EDIT_DESC=             Which line editing lib to use
 LIBEDIT_DESC=          Use libedit
 READLINE_DESC=         Use libreadline
-CAPIDOCS_BUILD_DEPENDS=        doxygen>1.8.12,2:devel/doxygen \
+CAPIDOCS_BUILD_DEPENDS=        doxygen>=1.8.12,2:devel/doxygen \
                        dot:graphics/graphviz
 CAPIDOCS_CONFIGURE_ENABLE=     install-capi
 GMP_CONFIGURE_WITH=    gmp

[1] https://svnweb.freebsd.org/changeset/ports/434270
Comment 1 commit-hook freebsd_committer 2017-02-27 06:38:44 UTC
A commit references this bug:

Author: sunpoet
Date: Mon Feb 27 06:37:46 UTC 2017
New revision: 434915
URL: https://svnweb.freebsd.org/changeset/ports/434915

Log:
  Fix doxygen version requirement

  PR:		217384
  Submitted by:	Yunchih Chen <yunchih@csie.ntu.edu.tw>

Changes:
  head/lang/ruby21/Makefile
  head/lang/ruby22/Makefile
  head/lang/ruby23/Makefile
  head/lang/ruby24/Makefile
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2017-02-27 06:38:57 UTC
Committed. Thanks!