Bug 217451 - shells/bash: default path includes the string %%LOCALBASE%%
Summary: shells/bash: default path includes the string %%LOCALBASE%%
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Emanuel Haupt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-01 14:15 UTC by Dan McGregor
Modified: 2017-03-01 15:24 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ehaupt)


Attachments
patch for LOCALBASE in default path. (1.48 KB, patch)
2017-03-01 14:15 UTC, Dan McGregor
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dan McGregor 2017-03-01 14:15:16 UTC
Created attachment 180393 [details]
patch for LOCALBASE in default path.

I expect this was intended to be replaced with the real value of LOCALBASE by the port Makefile at some point, but it isn't at the moment. I've attached a patch that sets this value in the Makefile.

With this patch, and one yet to be submitted against devel/bazel it is possible to build Gerrit on FreeBSD without any patches to Gerrit's code.
Comment 1 Emanuel Haupt freebsd_committer 2017-03-01 15:03:30 UTC
Good catch. I'll commit and MFH this shortly.
Comment 2 commit-hook freebsd_committer 2017-03-01 15:19:55 UTC
A commit references this bug:

Author: ehaupt
Date: Wed Mar  1 15:19:07 UTC 2017
New revision: 435164
URL: https://svnweb.freebsd.org/changeset/ports/435164

Log:
  Default path includes the string %%LOCALBASE%%. This was intended to be replaced
  with the real value of LOCALBASE by the port Makefile at some point, but it
  isn't at the moment.

  Set this value in the Makefile by defining CPPFLAGS accordingly.

  PR:             217451
  Submitted by:   Dan McGregor <dan.mcgregor@usask.ca>
  MFH:            2017Q1 (blanket)

Changes:
  head/shells/bash/Makefile
  head/shells/bash/files/patch-config-top.h
Comment 3 commit-hook freebsd_committer 2017-03-01 15:20:58 UTC
A commit references this bug:

Author: ehaupt
Date: Wed Mar  1 15:20:15 UTC 2017
New revision: 435165
URL: https://svnweb.freebsd.org/changeset/ports/435165

Log:
  MFH: r435164

  Default path includes the string %%LOCALBASE%%. This was intended to be replaced
  with the real value of LOCALBASE by the port Makefile at some point, but it
  isn't at the moment.

  Set this value in the Makefile by defining CPPFLAGS accordingly.

  PR:             217451
  Submitted by:   Dan McGregor <dan.mcgregor@usask.ca>
  Approved by:	ports-secteam (blanket)

Changes:
_U  branches/2017Q1/
  branches/2017Q1/shells/bash/Makefile
  branches/2017Q1/shells/bash/files/patch-config-top.h
Comment 4 Emanuel Haupt freebsd_committer 2017-03-01 15:24:46 UTC
Committed, thanks!