Bug 217627 - Not all files are removed when WITHOUT_AUDIT=YES
Summary: Not all files are removed when WITHOUT_AUDIT=YES
Status: Closed Feedback Timeout
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
: 217629 217631 217632 217633 217634 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-08 06:45 UTC by Sergey
Modified: 2018-02-14 18:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey 2017-03-08 06:45:55 UTC
WITHOUT_AUDIT=YES option doesn't remove /lib/libauditd, /etc/rc.d/auditd and /etc/rc.d/auditdistd

Though /lib/libauditd depends on libbsm (check /usr/src/lib/Makefile), neither of them are removed when both WITHOUT_AUDIT=YES and WITHOUT_BSNMP=YES are set.

Best regards.
Comment 1 Conrad Meyer freebsd_committer 2017-03-08 07:32:34 UTC
*** Bug 217634 has been marked as a duplicate of this bug. ***
Comment 2 Conrad Meyer freebsd_committer 2017-03-08 07:32:44 UTC
*** Bug 217633 has been marked as a duplicate of this bug. ***
Comment 3 Conrad Meyer freebsd_committer 2017-03-08 07:32:58 UTC
*** Bug 217632 has been marked as a duplicate of this bug. ***
Comment 4 Conrad Meyer freebsd_committer 2017-03-08 07:33:01 UTC
*** Bug 217631 has been marked as a duplicate of this bug. ***
Comment 5 Conrad Meyer freebsd_committer 2017-03-08 07:33:05 UTC
*** Bug 217629 has been marked as a duplicate of this bug. ***
Comment 6 Sergey 2017-03-08 14:23:26 UTC
Additionally,

WITHOUT_BSNMP=YES option doesn't remove /lib/libbsm and /lib/libbegemot

WITHOUT_QUOTAS=YES option doesn't remove /etc/rc.d/quota in file /usr/src/etc/rc.d/Makefile

WITHOUT_IPFILTER=YES option doesn't remove /etc/rc.d/ipfilter, /etc/rc.d/ipfs, etc/rc.d/ipmon and /etc/rc.d/ipnat in file /usr/src/etc/rc.d/Makefile

WITHOUT_PF=YES option doesn't remove /etc/rc.d/pf, /etc/rc.d/pflog and /etc/rc.d/pfsync in file /usr/src/etc/rc.d/Makefile

WITHOUT_SVNLITE=YES option doesn't remove /lib/libsqlite3 in file /usr/src/lib/Makefile

There is one note though, scripts in /etc/rc.d/ directory may depend on other scipts in same directory, so if some script is removed, sripts that are dependent on it should be handled properly.

Regards.