Bug 217734 - textproc/py-wtforms : update sqlachemy dependency to 1.0
Summary: textproc/py-wtforms : update sqlachemy dependency to 1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-03-12 21:21 UTC by Rene Ladan
Modified: 2017-03-28 20:18 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (rm)


Attachments
output of 'make test' (10.35 KB, text/plain)
2017-03-12 21:21 UTC, Rene Ladan
no flags Details
patch to update sqlalchemy dependency (760 bytes, patch)
2017-03-12 21:22 UTC, Rene Ladan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Ladan freebsd_committer 2017-03-12 21:21:29 UTC
Created attachment 180756 [details]
output of 'make test'

textproc/py-wtforms currently uses databases/py-sqlachemy08 as a test dependency, but this version is unsupported upstream and scheduled for removal on 2017-04-01.

Adjust wtforms to use py-sqlalchemy10 instead.

'make test' succeeds, see attachment.
Comment 1 Rene Ladan freebsd_committer 2017-03-12 21:22:55 UTC
Created attachment 180757 [details]
patch to update sqlalchemy dependency
Comment 2 Ruslan Makhmatkhanov freebsd_committer 2017-03-13 08:40:58 UTC
Thanks, I'll check how it's going with 1.0. Give me couple of days.
Comment 3 Rene Ladan freebsd_committer 2017-03-25 09:42:53 UTC
Any news?
Comment 4 Ruslan Makhmatkhanov freebsd_committer 2017-03-25 11:11:42 UTC
Oh, forgot(. Will do today. Sorry.
Comment 5 Rene Ladan freebsd_committer 2017-03-28 16:48:19 UTC
Ping? I'd like to commit the patch coming Friday to be able to clean up the old SQL Alchemy versions before 2017q2
Comment 6 commit-hook freebsd_committer 2017-03-28 20:16:20 UTC
A commit references this bug:

Author: rm
Date: Tue Mar 28 20:16:02 UTC 2017
New revision: 437155
URL: https://svnweb.freebsd.org/changeset/ports/437155

Log:
  textproc/py-wtforms: bump sqlalchemy dependency

  wtforms works fine sqlalchemy 1.0, so switch the port to it to
  get rid of sqlalchemy < 1.x.

  PR:		217734
  Submitted by:	rene

Changes:
  head/textproc/py-wtforms/Makefile
Comment 7 Ruslan Makhmatkhanov freebsd_committer 2017-03-28 20:18:28 UTC
Committed, thank you!

Sorry for delay. I needed to test wtforms with real application that is using sqlalchemy. Everything seems to work fine.