Bug 217737 - dns/unbound fails to build with python (swig dependency problem)
Summary: dns/unbound fails to build with python (swig dependency problem)
Status: Closed DUPLICATE of bug 218872
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-13 10:38 UTC by geoffroy desvernay
Modified: 2017-04-29 20:49 UTC (History)
3 users (show)

See Also:


Attachments
poudriere build log (9.71 KB, text/plain)
2017-03-13 10:38 UTC, geoffroy desvernay
no flags Details
Patch to fis problem (669 bytes, patch)
2017-03-13 15:28 UTC, Jaap Akkerhuis
no flags Details | Diff
Configures the proper version of swig (856 bytes, patch)
2017-03-23 11:39 UTC, Jaap Akkerhuis
jaap: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description geoffroy desvernay 2017-03-13 10:38:24 UTC
Created attachment 180762 [details]
poudriere build log

my poudriere dns/unbound fails to build since r435651 because of swig dependency update:

devel/swig30 does not provide 'swig' program as devel/swig13 but 'swig3.0'

This only affects builds with PYTHON option (not selected by default).
Comment 1 Jaap Akkerhuis 2017-03-13 15:28:06 UTC
Created attachment 180779 [details]
Patch to fis problem

Yikes. It seems that the last moment suggested update to a newer swig was a bad idea. The patch ai Will attach reverses this decision. Apologies.

        jaap
Comment 2 Walter Schwarzenfeld freebsd_triage 2017-03-15 05:00:03 UTC
I don't think the patch is the right solution.
I think
Makefile
+CONFIGURE_ARGS+=ac_cv_path_SWIG=${LOCALBASE}/bin/swig3.0

and change to:
PYTHON_BUILD_DEPENDS=    swig3.0:devel/swig30
Comment 3 Walter Schwarzenfeld freebsd_triage 2017-03-15 08:53:28 UTC
configure:
16867         # Extract the first word of "swig", so it can be a program name with args.
  16868 set dummy swig; ac_word=$2
  16869 { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
  16870 $as_echo_n "checking for $ac_word... " >&6; }
  16871 if ${ac_cv_path_SWIG+:} false; then :
  16872   $as_echo_n "(cached) " >&6
  16873 else
  16874   case $SWIG in
  16875   [\\/]* | ?:[\\/]*)
  16876   ac_cv_path_SWIG="$SWIG" # Let the user override the test with a path.
  16877   ;;
  16878   *)
  16879   as_save_IFS=$IFS; IFS=$PATH_SEPARATOR


Other ports set also explicit in different ways to swig (e.g graphics/geos)..
Comment 4 Walter Schwarzenfeld freebsd_triage 2017-03-15 08:57:35 UTC
Should be
....set the path to swig...
Comment 5 Jaap Akkerhuis 2017-03-15 09:12:55 UTC
(In reply to w.schwarzenfeld from comment #3)
The patch was just going back to the previous situation.

I'm travelling on the moment but will test you suggestion ASAP. Thanks!
Comment 6 Jaap Akkerhuis 2017-03-23 11:39:50 UTC
Created attachment 181094 [details]
Configures the proper version of swig

Uses the suggestion from w.schwarzenfeld. Thanks!
Comment 7 geoffroy desvernay 2017-04-06 10:46:29 UTC
tested here working. Thanks !

Hopefully a committer will take it quickly :)
Comment 8 Jaap Akkerhuis 2017-04-25 11:25:32 UTC
There is a new version of unbound released, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=218872, which makes this this moot.

We should close this.
Comment 9 Kurt Jaeger freebsd_committer 2017-04-29 20:49:37 UTC

*** This bug has been marked as a duplicate of bug 218872 ***