Bug 217940 - audio/wavpack fails in port with CCACHE
Summary: audio/wavpack fails in port with CCACHE
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-multimedia mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-20 07:29 UTC by Walter Schwarzenfeld
Modified: 2017-04-09 22:16 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (multimedia)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld freebsd_triage 2017-03-20 07:29:15 UTC
Wavpack fails with CCACHE with a bunch of errors like that (in the port 10.3-RELEASE-p17).

--- pack_x64.lo ---
<instantiation>:34:1: error: unknown token in expression
        sar eax, 10
^
pack_x64.S:1382:9: note: while in macro instantiation
        exeterm 18, 96
        ^
<instantiation>:36:15: error: unknown token in expression
        jmp 2f
              ^
pack_x64.S:1382:9: note: while in macro instantiation
        exeterm 18, 96
        ^
<instantiation>:43:9: error: unknown token in expression
2: je 3f
        ^
pack_x64.S:1382:9: note: while in macro instantiation
        exeterm 18, 96
        ^
<instantiation>:45:14: error: unknown token in expression
        je 3f
             ^
pack_x64.S:1382:9: note: while in macro instantiation
        exeterm 18, 96
        ^
<instantiation>:34:1: error: unknown token in expression
        sar eax, 10
^
pack_x64.S:1383:9: note: while in macro instantiation
        exeterm 17, -96
        ^
<instantiation>:36:15: error: unknown token in expression
        jmp 2f
              ^
pack_x64.S:1383:9: note: while in macro instantiation
        exeterm 17, -96
        ^
<instantiation>:43:9: error: unknown token in expression
2: je 3f
        ^
pack_x64.S:1383:9: note: while in macro instantiation
        exeterm 17, -96
        ^
<instantiation>:45:14: error: unknown token in expression
        je 3f
             ^
pack_x64.S:1383:9: note: while in macro instantiation
        exeterm 17, -96
        ^
<instantiation>:34:1: error: unknown token in expression
        sar eax, 10
^
pack_x64.S:1403:9: note: while in macro instantiation
        exeterm 18, 96
        ^
<instantiation>:36:15: error: unknown token in expression
        jmp 2f

....

is it possible to add something like:

.if defined(WITH_CCACHE_BUILD) && ${PORT_OPTIONS:MASM}
CFLAGS+=        -no-integrated-as
.endif

to the Makefile, will solve this.
Comment 1 Thomas Zander freebsd_committer 2017-04-01 17:17:40 UTC
Is this maybe due to a local issue with ccache? I am building this with ccache all the time and have observed this problem only when using clang before 3.9.
Comment 2 Walter Schwarzenfeld freebsd_triage 2017-04-01 20:15:27 UTC
No compiles with no clang version with CCACHE (10.3amd64).
Comment 3 Walter Schwarzenfeld freebsd_triage 2017-04-09 22:16:26 UTC
Now it works. I added export CCACHE_CPP2="YES" to the enviroment. But I don't
teally believe this was the problem.