Bug 217974 - sysutils/rdiff-backup: Limit to building with Python 2.x
Summary: sysutils/rdiff-backup: Limit to building with Python 2.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Martin Wilke
URL:
Keywords: easy, needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2017-03-21 09:54 UTC by Daniel Ylitalo
Modified: 2017-05-06 05:49 UTC (History)
4 users (show)

See Also:
daniel: maintainer-feedback+
uzsolt: maintainer-feedback+


Attachments
Force python2.7 (269 bytes, patch)
2017-03-21 09:54 UTC, Daniel Ylitalo
no flags Details | Diff
Force python2 (267 bytes, patch)
2017-03-22 15:14 UTC, Daniel Ylitalo
no flags Details | Diff
Limit to building with Python 2.x (270 bytes, patch)
2017-04-07 07:40 UTC, Daniel Ylitalo
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Ylitalo 2017-03-21 09:54:28 UTC
Created attachment 181023 [details]
Force python2.7

rdiff-backup does not build with python 3.5 so force it to 2.7 so you can build the ports tree with DEFAULT_VERSIONS python=3.5
Comment 1 Zsolt Udvari 2017-03-21 10:39:58 UTC
You've right, thanks!
Comment 2 Zsolt Udvari 2017-03-21 11:14:03 UTC
Maybe the "python:2" is enough, I think.
Comment 3 Daniel Ylitalo 2017-03-22 15:14:05 UTC
Created attachment 181059 [details]
Force python2

Changing to only require python 2.* instead of forcing 2.7
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2017-04-07 06:41:13 UTC
python:2 means depend on the lang/python2 port, specifically and only for the python2 (and other suffixed) symlinks. It does not mean 'depend on any 2.x version of Python'.

If rdiff-backup supports (upstream codes for, works and is tested with) 2.6 and 2.7, then '-2.7' is the most correct (precise without being incorrect).

If rdiff-backup only supports (upstream codes for, works and is tested with) 2.7, then =2.7 is the most correct.

Also, the summary for this issue appears in contradiction with comment 0. The summary states the change proposed is *allowing* building with 3.5, whereas the patch (and comment 0) changes the port to only build with 2.7 because 3.x does *not* work.

The issue summary needs to be updated to match whatever the proposed changeset (patch) does.
Comment 5 Daniel Ylitalo 2017-04-07 07:40:27 UTC
Created attachment 181562 [details]
Limit to building with Python 2.x
Comment 6 Daniel Ylitalo 2017-04-07 07:42:35 UTC
It supports 2.2 <-> 2.7 so going with python:-2.7
Comment 7 Zsolt Udvari 2017-04-11 15:10:20 UTC
Yes, rdiff-backup works well with python2.6 and python2.7 too. So I think the '-2.7' is a good choice.

Sorry for late.
Comment 8 commit-hook freebsd_committer 2017-05-06 05:49:09 UTC
A commit references this bug:

Author: miwi
Date: Sat May  6 05:48:14 UTC 2017
New revision: 440218
URL: https://svnweb.freebsd.org/changeset/ports/440218

Log:
  - Limit to build to python:2.7

  PR:		    217974
  Submitted by:	Daniel Ylitalo
  Approved by:	maintainer

Changes:
  head/sysutils/rdiff-backup/Makefile