Bug 217981 - deskutils/py-vdirsyncer: Update to 0.16.3
Summary: deskutils/py-vdirsyncer: Update to 0.16.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Dmitry Marakasov
URL:
Keywords:
: 221863 (view as bug list)
Depends on: 222730
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-21 16:31 UTC by Dmitry Marakasov
Modified: 2017-12-05 14:58 UTC (History)
6 users (show)

See Also:
ygy: maintainer-feedback-


Attachments
Updating to 0.16.2 (2.68 KB, patch)
2017-10-02 06:41 UTC, Alexandre C. Guimarães
no flags Details | Diff
Now updating to 0.16.3. (2.68 KB, patch)
2017-10-12 14:19 UTC, Alexandre C. Guimarães
no flags Details | Diff
The patch was switched to FLAVOURS. (2.00 KB, patch)
2017-12-01 00:40 UTC, Alexandre C. Guimarães
no flags Details | Diff
This patch was switched to FLAVOURS. (2.01 KB, patch)
2017-12-01 00:53 UTC, Alexandre C. Guimarães
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2017-03-21 16:31:49 UTC
vdirsyncer 0.12.1 was released half a year ago, the latest release is 0.15.0. The port needs updating.
Comment 1 Alexandre C. Guimarães freebsd_committer 2017-10-02 06:41:47 UTC
Created attachment 186851 [details]
Updating to 0.16.2

This patch does:

* update vdirsyncer to 0.16.2 version
* switch to DISTVERSION
* update the LICENSE to BSD3CLAUSE

The EteSync support was not added because it would require py-etesync to be ported, what would require several others python libraries to also be ported...

Thanks!
Comment 2 Alexandre C. Guimarães freebsd_committer 2017-10-02 06:42:32 UTC
Just now I saw it was already assigned to someone.
Comment 3 Guangyuan Yang freebsd_committer 2017-10-03 04:29:42 UTC
*** Bug 221863 has been marked as a duplicate of this bug. ***
Comment 4 Guangyuan Yang freebsd_committer 2017-10-12 13:38:20 UTC
FYI the newest version is 0.16.3 now.
Comment 5 Alexandre C. Guimarães freebsd_committer 2017-10-12 14:19:25 UTC
Created attachment 187106 [details]
Now updating to 0.16.3.
Comment 6 Alexandre C. Guimarães freebsd_committer 2017-12-01 00:40:48 UTC
Created attachment 188441 [details]
The patch was switched to FLAVOURS.
Comment 7 Alexandre C. Guimarães freebsd_committer 2017-12-01 00:42:51 UTC
BTW, it does not depends on #218935 anymore but I can't remove the tag.

Thanks!
Comment 8 Alexandre C. Guimarães freebsd_committer 2017-12-01 00:53:16 UTC
Created attachment 188442 [details]
This patch was switched to FLAVOURS.

Fix a optional dependency what also need a @${FLAVOR}.
Comment 9 commit-hook freebsd_committer 2017-12-05 10:37:27 UTC
A commit references this bug:

Author: amdmi3
Date: Tue Dec  5 10:37:16 UTC 2017
New revision: 455574
URL: https://svnweb.freebsd.org/changeset/ports/455574

Log:
  - Update to 0.16.3
  - Fix LICENSE

  PR:		217981
  Submitted by:	lbdm@privacychain.ch
  Reported by:	amdmi3
  Approved by:	maintainer timeout (che@bein.link, 8 months)

Changes:
  head/deskutils/py-vdirsyncer/Makefile
  head/deskutils/py-vdirsyncer/distinfo
Comment 10 Dmitry Marakasov freebsd_committer 2017-12-05 10:38:42 UTC
(fixed USES=python from 3.3+ to 3.4+ according to setup.py)
Comment 11 Dmitry Marakasov freebsd_committer 2017-12-05 10:40:02 UTC
(committer timeout as well)
Comment 12 Guangyuan Yang freebsd_committer 2017-12-05 14:58:46 UTC
(In reply to Dmitry Marakasov from comment #11)

Well, technically I just put on a review ~3hrs before your commit :-) Thanks.