Bug 218251 - graphics/dri does not compile with llvm40
Summary: graphics/dri does not compile with llvm40
Status: Closed DUPLICATE of bug 217016
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-31 09:08 UTC by Walter Schwarzenfeld
Modified: 2017-04-01 12:59 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld freebsd_triage 2017-03-31 09:08:32 UTC
Does not know how relevant it is.
I open it cause of a post on pipermail.
https://lists.freebsd.org/pipermail/freebsd-ports/2017-March/107951.html
In this post seems other things cause of the problem.

But I tried it.
With the same error message:
./gallivm/lp_bld_intr.h:69:20: error: unknown type name 'LLVMAttribute'; 
did you mean 'LLVMAttribu
teRef'?
                    LLVMAttribute attr);
                    ^~~~~~~~~~~~~
                    LLVMAttributeRef

Found this patch
https://lists.freedesktop.org/archives/mesa-dev/2016-November/134513.html

It solve a lot of error messages. Leaving two trivial errors, one in gallium/drivers/radeonsi/si_shader.c
and two in gallium/drivers/llvmpipe/lp_state_fs.c (They are same error as solved on other lines 
in the patch).

But it finally stops in gallium/drivers/llvmpipe/lp_state_fs.c cause it could not find
/usr/local/llvm40/include/llvm/Bitcode/ReaderWriter.h. It does not exist.

(so seems it is broken with llvm40).

As I said if it may be not relevant (cause MESA_LLVM_VER= 39 is explicit set in the
masterport (graphics/libGL). so please close it
Comment 1 Walter Schwarzenfeld freebsd_triage 2017-03-31 09:40:38 UTC
I puzzled the filenames. The header is missing in gallium/state_trackers/clover/llvm/codegen/bitcode.cpp.
Comment 2 Jan Beich freebsd_committer 2017-03-31 13:57:20 UTC
Probably a duplicate of bug 217016 or bug 218196.
Comment 3 Walter Schwarzenfeld freebsd_triage 2017-04-01 12:59:35 UTC
Yes is the same, so i close here.

*** This bug has been marked as a duplicate of bug 217016 ***