Bug 218272 - sysutils/qjail [Maintainer update] fix bugs
Summary: sysutils/qjail [Maintainer update] fix bugs
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Martin Wilke
URL:
Keywords:
: 218271 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-31 20:30 UTC by Joe Barbish
Modified: 2017-04-23 23:58 UTC (History)
4 users (show)

See Also:
junovitch: merge-quarterly+


Attachments
port diff (1.22 KB, patch)
2017-03-31 20:30 UTC, Joe Barbish
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Barbish 2017-03-31 20:30:32 UTC
Created attachment 181362 [details]
port diff

1. Some people have firewalls that are not or cannot be configured to allow ftp out. qjail used native ftp to download the base file issued by the "qjail install" logic. Changed it to use the "fetch http" command instead of the native ftp command. 

2. Installed the hs-shellcheck package. Used it to check the qjail script. Even though the qjail script has been in production mode for 7+ years, thought it would be good to verify the code was up to good standards. It found some things that were not up to standard that I fixed. The changes in no way effected the existing logic flow.

3. Ran the updated qjail script through a testing cycle looking for any problems that may have been caused by the shellcheck changes I made. None were found.

4. The testing cycle did bring to light three problems that unknowingly existed before the shellcheck changes were made.

   A. The verify_ip routine was not working correctly. Fixed it.
   B. The bpf devfs rule 50 was not working correctly. Fixed it.
   C. Added check to -d option [# of jails to duplicate] of the 
      create function. No IPv6 addresses are allowed, only a single
      IPv4 address is allowed.

5. Ran shellcheck on "qjail.bootime" script and fixed same kind of things as in the qjail script.
Comment 1 Kurt Jaeger freebsd_committer 2017-04-01 11:09:41 UTC
*** Bug 218271 has been marked as a duplicate of this bug. ***
Comment 2 Joe Barbish 2017-04-20 20:39:54 UTC
Is there some reason holding up commit of this pr?
If you just don't have time right now, please release this PR back into the pool so someone else can commit it.   Thanks
Comment 3 Martin Wilke freebsd_committer 2017-04-21 04:21:57 UTC
Sorry for the delay, committed thanks.
Comment 4 commit-hook freebsd_committer 2017-04-21 04:22:37 UTC
A commit references this bug:

Author: miwi
Date: Fri Apr 21 04:21:41 UTC 2017
New revision: 439000
URL: https://svnweb.freebsd.org/changeset/ports/439000

Log:
  - Update to 5.2

  PR:		218272

Changes:
  head/sysutils/qjail/Makefile
  head/sysutils/qjail/distinfo
Comment 5 Joe Barbish 2017-04-23 16:56:34 UTC
Re-opened
"Pending merge to quarterly request/commit"
Comment 6 commit-hook freebsd_committer 2017-04-23 23:51:29 UTC
A commit references this bug:

Author: junovitch
Date: Sun Apr 23 23:51:15 UTC 2017
New revision: 439264
URL: https://svnweb.freebsd.org/changeset/ports/439264

Log:
  MFH: r439000

  - Update to 5.2

  PR:		218272
  Approved by:	ports-secteam (with hat)

Changes:
_U  branches/2017Q2/
  branches/2017Q2/sysutils/qjail/Makefile
  branches/2017Q2/sysutils/qjail/distinfo
Comment 7 Jason Unovitch freebsd_committer 2017-04-23 23:58:45 UTC
(In reply to Joe Barbish from comment #5)
Sorry Joe I think it may have been overlooked at first. Merged.