Bug 218495 - [exp-run] Test for regex changes in D10315
Summary: [exp-run] Test for regex changes in D10315
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Port Management Team
URL: https://reviews.freebsd.org/D10315
Keywords:
Depends on: 218600 218601 218603 218604 218605 218606 219009
Blocks: 166861
  Show dependency treegraph
 
Reported: 2017-04-08 16:14 UTC by Pedro F. Giffuni
Modified: 2017-05-25 20:45 UTC (History)
3 users (show)

See Also:


Attachments
libc/regex changes (1.16 KB, patch)
2017-04-08 16:14 UTC, Pedro F. Giffuni
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro F. Giffuni freebsd_committer 2017-04-08 16:14:49 UTC
Created attachment 181601 [details]
libc/regex changes

The patch from Phabricator D10315 improves our standards conformance.
However, due to the long history of regex changes causing issues on sed I would like an exp-run.
Comment 2 Antoine Brodin freebsd_committer 2017-04-09 11:13:53 UTC
This is just the beginning of the exp-run.
Comment 3 Kyle Evans freebsd_committer 2017-04-09 13:24:06 UTC
(In reply to Antoine Brodin from comment #2)

I have a feeling this is going to be a bumpy ride, but hopefully this is a trend that continues. The three mentioned are legitimate abuse within the ports tree itself, with the latter two in the USES= elixir bits of the framework.
Comment 4 Kyle Evans freebsd_committer 2017-04-12 17:03:00 UTC
I went ahead and submitted some patches for the more obvious failures I was able to identify cross-referencing failures here with the run for PR 218385 as well as the amd64 run immediately preceding this one. I'm sure there are other failures that I'm missing, but this is a start. =)
Comment 5 Antoine Brodin freebsd_committer 2017-04-16 13:08:53 UTC
New failures:

+ {"origin"=>"archivers/star", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-apex", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-combine", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-connection", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-exactor", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-gen_state_machine", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-gettext", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-libring", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-math", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-msgpax", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-nats", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-nimble_csv", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-paratize", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-poison", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-stemmer", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/elixir-tzdata", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/psptoolchain-newlib", "phase"=>"patch", "errortype"=>"???"}
+ {"origin"=>"emulators/virtualbox-ose-additions", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"emulators/virtualbox-ose-additions-nox11", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"emulators/virtualbox-ose-kmod", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"games/fairymax", "phase"=>"patch", "errortype"=>"???"}
+ {"origin"=>"irc/irssi-xmpp", "phase"=>"patch", "errortype"=>"???"}
+ {"origin"=>"japanese/xdtp", "phase"=>"patch", "errortype"=>"???"}
+ {"origin"=>"mail/libcmime", "phase"=>"patch", "errortype"=>"???"}
+ {"origin"=>"misc/elixir-mime", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"textproc/elixir-earmark", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"www/elixir-html_entities", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"www/elixir-httpotion", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"www/elixir-phoenix_pubsub", "phase"=>"build", "errortype"=>"???"}


Failure logs:

http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/star-1.5.3.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-apex-1.0.0.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-combine-0.9.6.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-connection-1.0.4.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-exactor-2.2.3.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-gen_state_machine-2.0.0.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-gettext-0.13.1.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-libring-1.0.1.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-math-0.3.0.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-msgpax-1.0.0.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-nats-0.1.4.a.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-nimble_csv-0.1.1.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-paratize-2.1.4.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-poison-3.0.0.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-stemmer-1.0.1.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-tzdata-0.5.11.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/psptoolchain-newlib-1.20.0_1.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/virtualbox-ose-additions-5.1.18.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/virtualbox-ose-additions-nox11-5.1.18.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/virtualbox-ose-kmod-5.1.18.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/fairymax-5.0b.20160316.1.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/irssi-xmpp-0.53_1.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/ja-xdtp-1.5.0_5.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/libcmime-0.1.15_3.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-mime-1.1.0.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-earmark-1.1.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-html_entities-0.3.0.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-httpotion-3.0.2.log
http://package18.nyi.freebsd.org/data/headamd64D10315-default/2017-04-09_09h40m51s/logs/errors/elixir-phoenix_pubsub-1.0.1.log
Comment 6 Kyle Evans freebsd_committer 2017-04-16 17:51:44 UTC
Hmmm, I'm legitimately stumped by the archivers/star failure. I can't reproduce that one locally, but I can't find any recent relevant commits that might have fixed it.
Comment 7 Pedro F. Giffuni freebsd_committer 2017-04-27 15:11:01 UTC
Apparently this is done, except for star.

Any way to get more details on the star failure?
Comment 8 Antoine Brodin freebsd_committer 2017-04-27 15:14:46 UTC
I will do the exp-run again.
Comment 9 Antoine Brodin freebsd_committer 2017-05-01 06:14:06 UTC
There is 1 new failure on i386:

+ {"origin"=>"mail/spmfilter", "phase"=>"patch", "errortype"=>"???"}

Failure log:

http://pb2.nyi.freebsd.org/data/headi386D10315-default/2017-04-30_20h41m15s/logs/errors/spmfilter-0.6.7_4.log
Comment 10 Pedro F. Giffuni freebsd_committer 2017-05-25 20:35:39 UTC
Thanks for the exp-run !
The revision is not yet committed but from the testing POV, we are done now.