Bug 218591 - www/firefox Script "configure" failed unexpectedly.
Summary: www/firefox Script "configure" failed unexpectedly.
Status: Closed DUPLICATE of bug 218581
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-12 14:39 UTC by drhowarddrfine
Modified: 2017-04-12 14:49 UTC (History)
2 users (show)

See Also:
jbeich: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description drhowarddrfine 2017-04-12 14:39:28 UTC
Upgrading from 52.0.2 to 53

js/src> updating cache /usr/ports/www/firefox/work/firefox-53.0/obj-x86_64-unknown-freebsd11.0/config.cache
js/src> creating ./config.data
js/src> Creating config.status

Creating config.status
Traceback (most recent call last):
  File "/usr/ports/www/firefox/work/firefox-53.0/configure.py", line 124, in <module>
    sys.exit(main(sys.argv))
  File "/usr/ports/www/firefox/work/firefox-53.0/configure.py", line 34, in main
    return config_status(config)
  File "/usr/ports/www/firefox/work/firefox-53.0/configure.py", line 119, in config_status
    return config_status(args=[], **encode(sanitized_config, encoding))
  File "/usr/ports/www/firefox/work/firefox-53.0/python/mozbuild/mozbuild/config_status.py", line 136, in config_status
    reader = BuildReader(env)
  File "/usr/ports/www/firefox/work/firefox-53.0/python/mozbuild/mozbuild/frontend/reader.py", line 886, in __init__
    self._gyp_worker_pool = ProcessPoolExecutor(max_workers=max_workers)
  File "/usr/ports/www/firefox/work/firefox-53.0/python/futures/concurrent/futures/process.py", line 274, in __init__
    _check_system_limits()
  File "/usr/ports/www/firefox/work/firefox-53.0/python/futures/concurrent/futures/process.py", line 263, in _check_system_limits
    raise NotImplementedError(_system_limited)
NotImplementedError: system provides too few semaphores (30 available, 256 necessary)
*** Fix above errors and then restart with\
               "gmake -f client.mk build"
gmake[2]: *** [/usr/ports/www/firefox/work/firefox-53.0/client.mk:383: configure] Error 1
gmake[2]: Leaving directory '/usr/ports/www/firefox'
===>  Script "configure" failed unexpectedly.
Comment 1 drhowarddrfine 2017-04-12 14:40:17 UTC
There is nothing in /usr/ports/www/firefox/work/firefox-53.0/config.log
Comment 2 Walter Schwarzenfeld freebsd_triage 2017-04-12 14:46:21 UTC
see Bug 218581
Comment 3 Jan Beich freebsd_committer 2017-04-12 14:49:29 UTC
Duplicate based on ProcessPoolExecutor in the traceback.

*** This bug has been marked as a duplicate of bug 218581 ***