Bug 218642 - Fix build graphics/dri with VAAPI option enabled
Summary: Fix build graphics/dri with VAAPI option enabled
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
: 218674 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-13 19:19 UTC by Eric Camachat
Modified: 2017-05-11 08:50 UTC (History)
5 users (show)

See Also:
rezny: maintainer-feedback+


Attachments
Fix build graphics/dri with VAAPI option enabled (597 bytes, patch)
2017-04-13 19:19 UTC, Eric Camachat
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Camachat 2017-04-13 19:19:53 UTC
Created attachment 181766 [details]
Fix build graphics/dri with VAAPI option enabled
Comment 1 Matthew Rezny freebsd_committer 2017-04-14 15:24:58 UTC
Thanks for submitting the patch. I have confirmed the BUILD_DEPEND on v4l_compat is needed for VAAPI, but that alone appears to be sufficient to build with the option enabled in poudriere. What prompted the addition of VAAPI_LDFLAGS?
Comment 2 Jan Beich freebsd_committer 2017-04-15 07:46:13 UTC
*** Bug 218674 has been marked as a duplicate of this bug. ***
Comment 3 John Smith 2017-04-16 11:22:17 UTC
Eric Camachat,

Please, next time follow the bug reporting convention:
 	
Component Description

Individual Port or Package
Prefix the issue Summary field with category/port: so that MAINTAINER is Assigned or CC'd automatically.

Apart from auto assigning or auto CC'ing the maintainer - it helps others to not file duplicate issues.

About the patch: with it dri got successfully built for me by synth (which it failed to do without it).
Comment 4 Eric Camachat 2017-04-16 20:51:51 UTC
(In reply to Matthew Rezny from comment #1)
Linker complained some functions not found, I just added all libs that contents those function into VAAPI_LDFLAGS.
Comment 5 Eric Camachat 2017-04-16 20:52:42 UTC
(In reply to John Smith from comment #3)
Sure, I will follow the convention.
Comment 6 Jason E. Hale freebsd_committer 2017-04-18 12:16:10 UTC
Wouldn't it make more sense to add multimedia/v4l_compat as a RUN_DEPENDS to multimedia/libva instead? ${LOCALBASE}/include/va/va_backend.h has #include <linux/videodev2.h>, but since v4l_compat is only listed as a BUILD_DEPENDS in libva, anything including va_backend.h (like dri) in a clean environment will be broken.
Comment 7 Matthew Rezny freebsd_committer 2017-04-18 13:18:44 UTC
(In reply to Jason E. Hale from comment #6)

That is a good suggestion. I have not looked too close at libva, but that sounds like the right place to fix it if all dependents need the header.
Comment 8 Guido Falsi freebsd_committer 2017-04-18 15:25:29 UTC
(In reply to Matthew Rezny from comment #7)
> (In reply to Jason E. Hale from comment #6)
> 
> That is a good suggestion. I have not looked too close at libva, but that
> sounds like the right place to fix it if all dependents need the header.

Hi,

Since I maintain libva, and noticed this discussion (by chance) I'm adding myself here.

I need to look at this a little to really understand what's happening. I have no objection to adding a dependency in principle but let me study the situation and understand what's happening.

I'll report back ASAP.
Comment 9 Guido Falsi freebsd_committer 2017-04-19 09:17:50 UTC
The suggested fix of adding a RUN_DEPENDS on libva actually fixes the issue. I'll commit the update to libva after a little further testing.

Thanks for pointing this out!
Comment 10 commit-hook freebsd_committer 2017-04-19 14:32:09 UTC
A commit references this bug:

Author: madpilot
Date: Wed Apr 19 14:31:49 UTC 2017
New revision: 438845
URL: https://svnweb.freebsd.org/changeset/ports/438845

Log:
  Add a v4l_compat as RUN_DEPENDS too, as dri requires include files
  from this port when including optional VAAPI support.

  PR:		218642
  Submitted by:	Eric Camachat <eric@camachat.org>
  Suggested by:	jhale@

Changes:
  head/multimedia/libva/Makefile
Comment 11 Guido Falsi freebsd_committer 2017-05-11 08:26:40 UTC
Hi,

does r438845 completely fix this problem? Can I close this bug report as fixed?
Comment 12 Matthew Rezny freebsd_committer 2017-05-11 08:42:51 UTC
(In reply to Guido Falsi from comment #11)

Yes, it's fixed, go head and close it.