Bug 218675 - www/firefox: NotImplementedError: system provides too few semaphores
Summary: www/firefox: NotImplementedError: system provides too few semaphores
Status: Closed DUPLICATE of bug 218581
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-15 08:13 UTC by O. Hartmann
Modified: 2017-04-15 08:16 UTC (History)
0 users

See Also:
jbeich: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2017-04-15 08:13:31 UTC
On several recent CURRENT boxes I face the error shown below when building www/firefox. The error also occurs on poudriere building hosts, not all, but all of them are CURRENT and more or less the same OS and ports tree revision (with a day delay between updates). All amd64.

Regards,
oh

[...]
Creating config.status
Traceback (most recent call last):
  File "/usr/ports/www/firefox/work/firefox-53.0/configure.py", line 124, in <module>
    sys.exit(main(sys.argv))
  File "/usr/ports/www/firefox/work/firefox-53.0/configure.py", line 34, in main
    return config_status(config)
  File "/usr/ports/www/firefox/work/firefox-53.0/configure.py", line 119, in config_status
    return config_status(args=[], **encode(sanitized_config, encoding))
  File "/usr/ports/www/firefox/work/firefox-53.0/python/mozbuild/mozbuild/config_status.py", line 136, in config_status
    reader = BuildReader(env)
  File "/usr/ports/www/firefox/work/firefox-53.0/python/mozbuild/mozbuild/frontend/reader.py", line 886, in __init__
    self._gyp_worker_pool = ProcessPoolExecutor(max_workers=max_workers)
  File "/usr/ports/www/firefox/work/firefox-53.0/python/futures/concurrent/futures/process.py", line 274, in __init__
    _check_system_limits()
  File "/usr/ports/www/firefox/work/firefox-53.0/python/futures/concurrent/futures/process.py", line 263, in _check_system_limits
    raise NotImplementedError(_system_limited)
NotImplementedError: system provides too few semaphores (30 available, 256 necessary)
*** Fix above errors and then restart with\
               "gmake -f client.mk build"
gmake[2]: *** [/usr/ports/www/firefox/work/firefox-53.0/client.mk:383: configure] Error 1
gmake[2]: Leaving directory '/usr/ports/www/firefox'
===>  Script "configure" failed unexpectedly.
Please report the problem to gecko@FreeBSD.org [maintainer] and attach the
"/usr/ports/www/firefox/work/firefox-53.0/config.log" including the output
of the failure of your make command. Also, it might be a good idea to provide
an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/firefox
*** Error code 1
Comment 1 Jan Beich freebsd_committer 2017-04-15 08:16:06 UTC
Don't use sem(4) or pick up base r316739 fix.

*** This bug has been marked as a duplicate of bug 218581 ***