Bug 218765 - c++: error: unable to execute command: Bus error while in buildworld
Summary: c++: error: unable to execute command: Bus error while in buildworld
Status: Closed Feedback Timeout
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 11.0-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-20 01:41 UTC by goto-freebsd
Modified: 2018-05-21 07:41 UTC (History)
1 user (show)

See Also:


Attachments
Preprocessed source(s) and associated run script(s) (384.32 KB, application/x-zip-compressed)
2017-04-20 01:41 UTC, goto-freebsd
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description goto-freebsd 2017-04-20 01:41:06 UTC
Created attachment 181923 [details]
Preprocessed source(s) and associated run script(s)

--------------------------------------------------------------
>>> stage 1.2: bootstrap tools
--------------------------------------------------------------
cd /usr/fs/src; MAKEOBJDIRPREFIX=/usr/obj/usr/fs/src/tmp  INSTALL="sh /usr/fs/src/tools/install.sh"  TOOLS_PREFIX=/usr/obj/usr/fs/src/tmp  PATH=/usr/obj/usr/fs/src/tmp/legacy/usr/sbin:/usr/obj/usr/fs/src/tmp/legacy/usr/bin:/usr/obj/usr/fs/src/tmp/legacy/bin:/sbin:/bin:/usr/sbin:/usr/bin  WORLDTMP=/usr/obj/usr/fs/src/tmp  MAKEFLAGS="-m /usr/fs/src/tools/build/mk  -m /usr/fs/src/share/mk" make  -f Makefile.inc1  DESTDIR=  BOOTSTRAPPING=1100510  SSP_CFLAGS=  MK_HTML=no NO_LINT=yes MK_MAN=no  -DNO_PIC MK_PROFILE=no -DNO_SHARED  -DNO_CPU_CFLAGS MK_WARNS=no MK_CTF=no  MK_CLANG_EXTRAS=no MK_CLANG_FULL=no  MK_LLDB=no MK_TESTS=no  MK_INCLUDES=yes bootstrap-tools
===> lib/clang/libllvmminimal (obj,all,install)
/usr/obj/usr/fs/src/tmp/usr/fs/src/lib/clang/libllvmminimal created for /usr/fs/src/lib/clang/libllvmminimal
/usr/obj/usr/fs/src/tmp/usr/fs/src/lib/clang/libllvmminimal/Support created for /usr/fs/src/lib/clang/libllvmminimal
/usr/obj/usr/fs/src/tmp/usr/fs/src/lib/clang/libllvmminimal/TableGen created for /usr/fs/src/lib/clang/libllvmminimal
c++  -O2 -pipe -I/usr/fs/src/lib/clang/include -I/usr/fs/src/contrib/llvm/include -DLLVM_ON_UNIX -DLLVM_ON_FREEBSD -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS -DNDEBUG -DLLVM_DEFAULT_TARGET_TRIPLE=\"x86_64-unknown-freebsd11.0\" -DLLVM_HOST_TRIPLE=\"x86_64-unknown-freebsd11.0\" -DDEFAULT_SYSROOT=\"/usr/obj/usr/fs/src/tmp\" -MD -MF.depend.Support_APInt.o -MTSupport/APInt.o -Qunused-arguments -I/usr/obj/usr/fs/src/tmp/legacy/usr/include -std=c++11 -fno-exceptions -fno-rtti  -stdlib=libc++ -Wno-c++11-extensions  -c /usr/fs/src/contrib/llvm/lib/Support/APInt.cpp -o Support/APInt.o
c++: error: unable to execute command: Bus error
c++: error: clang frontend command failed due to signal (use -v to see invocation)
FreeBSD clang version 3.9.1 (tags/RELEASE_391/final 289601) (based on LLVM 3.9.1)
Target: x86_64-unknown-freebsd11.0
Thread model: posix
InstalledDir: /usr/bin
c++: note: diagnostic msg: PLEASE submit a bug report to https://bugs.freebsd.org/submit/ and include the crash backtrace, preprocessed source, and associated run script.
c++: note: diagnostic msg: 
********************

PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
Preprocessed source(s) and associated run script(s) are located at:
c++: note: diagnostic msg: /tmp/APInt-a45e81.cpp
c++: note: diagnostic msg: /tmp/APInt-a45e81.sh
c++: note: diagnostic msg: 

********************
*** Error code 254

Stop.
make[3]: stopped in /usr/fs/src/lib/clang/libllvmminimal
*** Error code 1

Stop.
make[2]: stopped in /usr/fs/src
*** Error code 1

Stop.
make[1]: stopped in /usr/fs/src
*** Error code 1

Stop.
make: stopped in /usr/fs/src
Comment 1 Dimitry Andric freebsd_committer 2017-04-20 07:04:59 UTC
I cannot reproduce your crash, neither with clang 3.9.1 nor with 4.0.0.  Is this machine low on memory during the bootstrap build?  Or has the system compiler /usr/bin/c++ been built with special options?  (E.g. CPUTYPE or -march= settings, which may have been different from your actual host CPU.)
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2018-05-21 00:00:02 UTC
For bugs matching the following conditions:
- Status == In Progress
- Assignee == "bugs@FreeBSD.org"
- Last Modified Year <= 2017

Do
- Set Status to "Open"