Bug 218897 - /etc/skel is a directory with no functionality whatsoever
Summary: /etc/skel is a directory with no functionality whatsoever
Status: Closed DUPLICATE of bug 46062
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 11.0-STABLE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-26 18:06 UTC by ASV
Modified: 2019-02-22 17:13 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ASV 2017-04-26 18:06:07 UTC
This may be a duplicate of Bug 46062. If so please close this and complete the other or vice versa.

As recently discussed in the email thread created by myself "/etc/skel doesn't work?!" (dated: Mon, 06 Mar 2017 12:25:22 -0300) on freebsd-questions, appears quite clear (as pointed out by Arthur Chance) that /etc/skel has been added by Jordan Hubbard on Feb 27th 1998 with the comment:

"MFC: /etc/skel doesn't seem to be used in the -current branch either,
but it doesn't hurt."

At present time /etc/skel has no functionality whatsoever, is a dead directory, a leftover dragged until now on the base system from an unclear intention dated almost 20 years back.

It causes confusion, is useless, I believe it is the right time to delete it.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:19:31 UTC
I believe this is a duplicate of Bug 46062 which I just spent a little time looking into.(In reply to ASV from comment #0)

*** This bug has been marked as a duplicate of bug 46062 ***
Comment 2 commit-hook freebsd_committer 2017-12-31 07:26:20 UTC
A commit references this bug:

Author: eadler
Date: Sun Dec 31 07:25:56 UTC 2017
New revision: 327421
URL: https://svnweb.freebsd.org/changeset/base/327421

Log:
  mtree: remove /etc/skel

  We use /usr/share/skel instead of /etc/skel. The existence of /etc/skel
  has confused people.

  PR:		46062 (submitted 2002-12-07)
  PR:		218897
  Submitted by:	carl@slackerbsd.org
  Submitted by:	asv@inhio.net

Changes:
  head/ObsoleteFiles.inc
  head/etc/mtree/BSD.root.dist