Bug 218900 - lang/swift: Missing lang/libobjc2 dependency and Makefile warning fixes
Summary: lang/swift: Missing lang/libobjc2 dependency and Makefile warning fixes
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Rene Ladan
URL:
Keywords:
: 225660 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-27 02:48 UTC by Lacey Powers
Modified: 2019-08-27 18:44 UTC (History)
5 users (show)

See Also:


Attachments
Makefile patch adding lang/libobjc2 as a build dep and warnings fixes (997 bytes, patch)
2017-04-27 02:48 UTC, Lacey Powers
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lacey Powers 2017-04-27 02:48:29 UTC
Created attachment 182114 [details]
Makefile patch adding lang/libobjc2 as a build dep and warnings fixes

Hi,

I was trying out the updated lang/swift port on FreeBSD 11.0-RELEASE-p9, and was trying to build from complete scratch and ran into build issues resulting from not having lang/libobjc2 installed.

Once I added that, I could build without failing, though there were the following warnings related to ncurses and execinfo that came up.

Attached is a patch to fix the warnings and the missing libobjc2.so build dependency.

Thanks again for getting this working. I'm looking forward to experimenting further with Swift. =)
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-01-10 03:41:44 UTC
Maintainer feedback?
Comment 2 David Chisnall freebsd_committer 2018-01-10 10:12:29 UTC
Why does Swift need libobjc2 to build?  The Swift / ObjC interop isn't implemented for non-Apple runtimes yet.
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-08-04 18:40:12 UTC
Port is expired: EXPIRATION_DATE=        2019-05-08.
Comment 4 Rene Ladan freebsd_committer 2019-08-11 20:55:27 UTC
The port does not build in a 12.0-amd64 poudriere with binutils and objc added. Perhaps it is time to remove this port?
Comment 5 Rene Ladan freebsd_committer 2019-08-11 20:56:29 UTC
*** Bug 225660 has been marked as a duplicate of this bug. ***
Comment 6 Rene Ladan freebsd_committer 2019-08-27 18:44:38 UTC
Expired port removed.