Bug 218961 - net-p2p/namecoin: Update to 0.13.2
Summary: net-p2p/namecoin: Update to 0.13.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2017-04-30 01:06 UTC by Chad Jacob Milios
Modified: 2018-09-05 20:52 UTC (History)
2 users (show)

See Also:
milios: maintainer-feedback+


Attachments
svn diff updating namecoin, namecoin-daemon, namecoin-utils (19.07 KB, patch)
2017-04-30 01:06 UTC, Chad Jacob Milios
no flags Details | Diff
svn diff updating namecoin, namecoin-daemon, namecoin-utils (19.07 KB, patch)
2017-07-22 06:10 UTC, Chad Jacob Milios
no flags Details | Diff
shar of net-p2p/namecoin{,-stable,-beta}{,-daemon,-utils} (42.35 KB, text/plain)
2018-04-25 20:35 UTC, Chad Jacob Milios
milios: maintainer-approval+
Details
shar of net-p2p/namecoin{,-stable,-beta}{,-daemon,-utils} (41.37 KB, text/plain)
2018-04-25 22:02 UTC, Chad Jacob Milios
milios: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chad Jacob Milios 2017-04-30 01:06:24 UTC
Created attachment 182182 [details]
svn diff updating namecoin, namecoin-daemon, namecoin-utils

tested on freebsd 11.0-RELEASE/amd64
Comment 1 Chad Jacob Milios 2017-05-07 13:12:21 UTC
i've made available some additional ports, for interested users and testers. i've been using the -stable version with no incident.

namecoin-legacy-0.3.80
namecoin-stable-0.13.99b1
namecoin-devel-0.14.1p1
namecoin-head-0.14.99a1

all of those ports (along with their -daemon and -utils counterparts) can be found in this shar:

https://raw.githubusercontent.com/CropCircleSys/nuOS/master/pkg/net-p2p_namecoin-devel.shar

(content at that link may occasionally be updated further)
Comment 2 Chad Jacob Milios 2017-07-22 06:10:31 UTC
Created attachment 184586 [details]
svn diff updating namecoin, namecoin-daemon, namecoin-utils

github rerolled the distfile. i inspected the difference and then reran make makesum. there was no meaningful change.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2017-07-23 12:07:50 UTC
Thank you Milios. Could you please:

- Clarify what testing was performed and whether that included portlint/poudriere QA confirmation
- Set the maintainer-approval attachment flag to + to designate maintainer patches/approval. Attachment -> Details -> maintainer-approval [+]
Comment 4 Chad Jacob Milios 2017-08-06 17:23:48 UTC
So far I've only used ports and make on FreeBSD 11.0 and 11.1 for amd64. I'll lint and QA run this in the coming few weeks. I'm investigating a poudriere setup.

I've been running full nodes concurrently with both this namecoin port and this supplemental namecoin-stable port. Using the GUI, CLI and REST interfaces I have registered/updated many names, generated many wallets, received and redeemed/sent many coins using both simple and script hash addresses, exported and imported some keys, indexed name_history.

I'm unhurried in committing this, just wanted to make the work available. The project is in a sort of alpha status with a total rewrite going on and hasn't in ages put out a cut and dried "release" blessed for production use. The namecoin port attached does represent a minor regression of GUI features relative to namecoin currently in ports tree (copied to namecoin-legacy in the supplemental ports here) but is functionally production ready.

I'll attach QA output for namecoin 0.13.2 as I am able.
Comment 5 Yuri Victorovich freebsd_committer 2018-02-25 02:07:02 UTC
ping
Comment 6 Chad Jacob Milios 2018-02-25 03:46:18 UTC
hello. i'll wrap this up before too long. should build fine still. i've been using namecoin-stable from the linked sharfile for many months now with great success. (https://raw.githubusercontent.com/CropCircleSys/nuOS/master/pkg/net-p2p_namecoin-devel.shar)

i'll update namecoin-devel to 0.15.99-name-tab-beta1 before the next week or two is up.
Comment 7 Chad Jacob Milios 2018-03-24 14:04:48 UTC
namecoin is changing a lot currently upstream. i will add another port the shar in the next few days namecoin-beta which will be 0.15.99b2.

i recommend using namecoin-stable from the shar file at the github user content link in the earlier comment for now. it is what i have personally tested most. it is version 0.13.99b1.
Comment 8 Chad Jacob Milios 2018-04-25 18:08:15 UTC
i have made available namecoin-stable (0.13.99-name-tab-beta1) as well as namecoin-beta (0.15.99-name-tab-beta2) in this shar:

https://raw.githubusercontent.com/CropCircleSys/nuOS/master/pkg/net-p2p_namecoin-beta.shar

i will retest the namecoin port (0.13.2) attached to this PR, ensure i also fix #224186 and close both these PRs as soon as i am able

i regret i've been slow moving as of late. i've been enduring some family turmoil though i'm hoping what i see is a light at the end of the tunnel now
Comment 9 Chad Jacob Milios 2018-04-25 20:35:11 UTC
Created attachment 192817 [details]
shar of net-p2p/namecoin{,-stable,-beta}{,-daemon,-utils}

because this is a shar archive rather than a diff, be sure to first:

rm -r /usr/ports/net-p2p/namecoin*

before you:

cd /usr/ports/net-p2p && shar /path/to/this/namecoin.shar
Comment 10 Chad Jacob Milios 2018-04-25 22:02:42 UTC
Created attachment 192818 [details]
shar of net-p2p/namecoin{,-stable,-beta}{,-daemon,-utils}

portlint had me reorder some things

this is a shar so be sure to `rm -r /usr/ports/net-p2p/namecoin*` first before you `cd /usr/ports/net-p2p && sh /path/to/this/namecoin.shar`
Comment 11 Chad Jacob Milios 2018-05-20 18:37:45 UTC
please can i get a committer to review at least namecoin{,-daemon,-util} and commit these three ports. i approve all 9 ports in this shar namecoin{,-stable,-beta}{,-daemon,-util} as ready for inclusion to the ports tree

thank you all!
Comment 12 Rene Ladan freebsd_committer 2018-09-02 18:22:51 UTC
namecoin, namecoin-daemon and namecoin-utils build fine on 10.4-i386 (I'll test on other versions/platforms too)
namecoin-stable and namecoin-beta have a missing dependency in their Makefile regarding QT, I'll look into that. This is something poudriere catches.

namecoin-stable does have another failure when building on my laptop itself (i.e. `cd /usr/ports/net/p2p/namecoin-stable ; make` ) :

> ...
> QT_SELECT=qt5 /usr/local/lib/qt5/bin/lrelease -silent qt/locale/bitcoin_bg.ts -qm qt/locale/bitcoin_bg.qm
> ld-elf.so.1: /usr/local/lib/qt5/bin/lrelease: Undefined symbol " _ZN14QLocalePrivate17getLangAndCountryERK7QStringRN7QLocale8LanguageERNS3_6ScriptERNS3_7CountryE@Qt_5_PRIVATE_API"

I'll retest this in poudriere too. This with with qt5 5.10.1 and boost 1.68.0
Comment 13 Rene Ladan freebsd_committer 2018-09-02 18:26:25 UTC
Same problem now for namecoin-beta:

> QT_SELECT=qt5 /usr/local/lib/qt5/bin/lrelease -silent qt/locale/bitcoin_ar.ts -qm qt/locale/bitcoin_ar.qm
> ld-elf.so.1: /usr/local/lib/qt5/bin/lrelease: Undefined symbol "_ZN14QLocalePrivate17getLangAndCountryERK7QStringRN7QLocale8LanguageERNS3_6ScriptERNS3_7CountryE@Qt_5_PRIVATE_API"
Comment 14 Chad Jacob Milios 2018-09-02 18:28:58 UTC
thank you. will probably bring this up to v0.16.2 in the next few days as well
Comment 15 Rene Ladan freebsd_committer 2018-09-02 19:26:40 UTC
OK, I'll commit the QT4-based variants of namecoin after some more tests in the meantime.
Comment 16 commit-hook freebsd_committer 2018-09-03 18:40:07 UTC
A commit references this bug:

Author: rene
Date: Mon Sep  3 18:39:52 UTC 2018
New revision: 478891
URL: https://svnweb.freebsd.org/changeset/ports/478891

Log:
  net-p2p/namecoin[-daemon]: unbreak, unexpire, update to 0.13.2

  This is part one of the PR.

  PR:		218961
  Submitted by:	maintainer

Changes:
  head/net-p2p/namecoin/Makefile
  head/net-p2p/namecoin/distinfo
  head/net-p2p/namecoin/files/makefile.unix
  head/net-p2p/namecoin/files/namecoind.in
  head/net-p2p/namecoin/files/patch-src__main.h
  head/net-p2p/namecoin/files/patch-src__qt__configurenamedialog.h
  head/net-p2p/namecoin/files/patch-src__qt__managenamespage.h
  head/net-p2p/namecoin/files/patch-src__strlcpy.h
  head/net-p2p/namecoin/files/patch-src_miner.h
  head/net-p2p/namecoin/files/patch-src_txmempool.h
  head/net-p2p/namecoin/pkg-descr
  head/net-p2p/namecoin-daemon/Makefile
Comment 17 commit-hook freebsd_committer 2018-09-03 18:46:13 UTC
A commit references this bug:

Author: rene
Date: Mon Sep  3 18:45:21 UTC 2018
New revision: 478893
URL: https://svnweb.freebsd.org/changeset/ports/478893

Log:
  Add new port net-p2p/namecoin-utils, a slave port containing utilities for
  net-p2p/namecoin

  PR:		218961
  Submitted by:	milios@ccsys.com

Changes:
  head/net-p2p/Makefile
  head/net-p2p/namecoin-utils/
  head/net-p2p/namecoin-utils/Makefile
Comment 18 Rene Ladan freebsd_committer 2018-09-05 19:50:07 UTC
Note that the stable and beta versions are not yet committed, so you might want to re-open this PR?
Comment 19 Chad Jacob Milios 2018-09-05 20:52:43 UTC
Nah, don't worry about those. They're both behind the v0.16.2 in PR #231167 now, which is a release version. If i feel the need for a -beta again i'll submit a new PR. I may put one together some day. As of right now it seems that the guy working on the "Manage Names Tab" GUI (the work i'd pulled into the -beta port) has some other things sapping his free time.