Bug 218998 - editors/libreoffice "libharfbuzz.so.0" not found
Summary: editors/libreoffice "libharfbuzz.so.0" not found
Status: Closed DUPLICATE of bug 219008
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-01 13:25 UTC by bsd
Modified: 2017-05-04 06:41 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bsd 2017-05-01 13:25:22 UTC
After updating to latest version, launching LibreOffice from terminal (Konsole) throws the following error:

Shared object "libharfbuzz.so.0" not found, required by "libvcllo.so"

uname -a:
FreeBSD lisp 11.0-RELEASE-p9 FreeBSD 11.0-RELEASE-p9 #0: Tue Apr 11 08:48:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

I am using KDE.
Comment 1 bsd 2017-05-01 13:51:49 UTC
I see other ports are affected, all seems related to "libharfbuzz.so.0" not found.

Could it the "Split off the harfbuzz icu support into it's own port." recent change?

Anyway, it seems not specific to LibreOffice per se, so, feel free to close this ticket.

[Note to self: always use beadm before *any* update]
Comment 2 Koop Mast freebsd_committer 2017-05-04 06:41:36 UTC
Seems to be a pkg bug. Which already has a PR open for it.

*** This bug has been marked as a duplicate of bug 219008 ***