Bug 219081 - www/obhttpd: Fix libressl build dependency
Summary: www/obhttpd: Fix libressl build dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
: 213822 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-05 09:00 UTC by Nikola Kolev
Modified: 2018-01-10 09:43 UTC (History)
1 user (show)

See Also:
koue: maintainer-feedback+


Attachments
obhttpd-libressl-patch (2.26 KB, text/plain)
2017-05-05 09:00 UTC, Nikola Kolev
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikola Kolev 2017-05-05 09:00:02 UTC
Created attachment 182317 [details]
obhttpd-libressl-patch

1) In libressl asn1_time_parse has been renamed to ASN1_time_parse and this cause build error. files/patch-lib_libtls_tls__conninfo.c will fix this issue.
2) Build obhttpd even if SSL_DEFAULT is not libressl.

Poudriere logs look OK.
Comment 1 commit-hook freebsd_committer 2017-11-09 23:07:42 UTC
A commit references this bug:

Author: swills
Date: Thu Nov  9 23:06:50 UTC 2017
New revision: 453878
URL: https://svnweb.freebsd.org/changeset/ports/453878

Log:
  www/obhttpd: Fix libressl build dependency

  PR:		219081
  Submitted by:	Nikola Kolev <koue@chaosophia.net> (maintainer)

Changes:
  head/www/obhttpd/Makefile
  head/www/obhttpd/files/patch-lib_libtls_tls__conninfo.c
Comment 2 Steve Wills freebsd_committer 2017-11-09 23:08:04 UTC
Committed, thanks!
Comment 3 Jan Beich freebsd_committer 2018-01-10 09:43:15 UTC
*** Bug 213822 has been marked as a duplicate of this bug. ***