Bug 219111 - mark various gnome@ ports BROKEN on tier-2
Summary: mark various gnome@ ports BROKEN on tier-2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-06 21:42 UTC by Mark Linimon
Modified: 2017-05-15 21:43 UTC (History)
4 users (show)

See Also:


Attachments
patch to various gnome@ ports (1.90 KB, patch)
2017-05-06 21:47 UTC, Mark Linimon
no flags Details | Diff
patch to various gnome@ ports (2.02 KB, patch)
2017-05-07 16:16 UTC, Mark Linimon
no flags Details | Diff
patch to mark graphics/gegl broken (429 bytes, patch)
2017-05-14 07:40 UTC, Mark Linimon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon freebsd_committer freebsd_triage 2017-05-06 21:42:34 UTC
I am going through the tier-2 build logs and marking various things BROKEN.  I do not have the time to fix these at the moment.  There is no reason to try to build them over and over again during package builds.

Patches welcome.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2017-05-06 21:47:57 UTC
Created attachment 182352 [details]
patch to various gnome@ ports
Comment 2 Mikael Urankar freebsd_committer 2017-05-07 09:50:02 UTC
A few notes for armv6:

www/webkit-gtk2: it's a clang bug, there is an opened pr upstream: https://bugs.llvm.org/show_bug.cgi?id=32825

www/webkit-gtk3: there is 2 opened pr with patches: bug #213961 bug #216147
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2017-05-07 16:16:28 UTC
Created attachment 182365 [details]
patch to various gnome@ ports
Comment 4 Jan Beich freebsd_committer 2017-05-07 17:29:11 UTC
Comment on attachment 182365 [details]
patch to various gnome@ ports

> +++ graphics/gegl/Makefile	(working copy)
[...]
> +BROKEN_aarch64=		fails to build: Segmentation fault (core dumped)

Maybe describe which binary crashes.

> +++ www/webkit-gtk2/Makefile	(working copy)
[...]
> +BROKEN_aarch64=		fails to build: runaway build

Which version?

http://thunderx1.nyi.freebsd.org/data/110arm64-default/439778/logs/webkit-gtk2-2.4.11_8.log
http://thunderx1.nyi.freebsd.org/data/110arm64-quarterly/440108/logs/webkit-gtk2-2.4.11_7.log

> +++ www/webkit-gtk3/Makefile	(working copy)
[...]
> +BROKEN_aarch64=		fails to build: runaway build

File a bug against poudriere instead. Some commands require more than 3600 seconds to complete.
The port builds fine on /branches/2017Q2 suggesting the issue is transient.

http://thunderx1.nyi.freebsd.org/data/110arm64-quarterly/440108/logs/webkit-gtk3-2.4.11_6.log

> +++ x11-toolkits/bakery/Makefile	(working copy)
[...]
> +BROKEN_aarch64=		fails to build: libbakery-2.6.la:No such file or directory

Out of date.

http://thunderx1.nyi.freebsd.org/data/latest-per-pkg/bakery/2.6.3_10/110arm64-default.log
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2017-05-14 07:40:47 UTC
Created attachment 182582 [details]
patch to mark graphics/gegl broken

Updated patch with OBE ports removed and feedback incorporated.
Comment 6 commit-hook freebsd_committer 2017-05-15 21:43:49 UTC
A commit references this bug:

Author: kwm
Date: Mon May 15 21:43:29 UTC 2017
New revision: 440976
URL: https://svnweb.freebsd.org/changeset/ports/440976

Log:
  Mark broken on aarch64.

  PR:		219111
  Submitted by:	linimon@

Changes:
  head/graphics/gegl/Makefile