Bug 219186 - x11-toolkits/swt-devel: Update to latest version
Summary: x11-toolkits/swt-devel: Update to latest version
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Max Brazhnikov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-10 08:04 UTC by bsd
Modified: 2019-10-01 09:21 UTC (History)
7 users (show)

See Also:
yuri: maintainer-feedback+
makc: maintainer-feedback+
yuri: maintainer-feedback+


Attachments
patch for audio/tuxguitar (2.31 KB, patch)
2019-09-29 18:22 UTC, Max Brazhnikov
yuri: maintainer-approval+
Details | Diff
patch for java/openjfx8-devel (1.24 KB, patch)
2019-09-30 20:10 UTC, Max Brazhnikov
tobik: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description bsd 2017-05-10 08:04:28 UTC
On FreeBSD 11.0-RELEASE-p9, launching SmartGit 17.0.3 (http://www.syntevo.com/smartgit/download) throws error:

smartgit % bin/smartgit.sh
Outdated SWT version detected! Aborting.

Would it be possible to update swt-devel to latest version?
Comment 1 bsd 2017-05-10 08:06:07 UTC
By the way, old, non-supported SmartGit 8.0.4 still works with current swt-devel.

To test, make sure to copy:

cp /usr/local/share/java/classes/swt-devel.jar lib/org.eclipse.swt.gtk.freebsd.x86_64.jar
Comment 2 Keren Sky 2017-08-03 23:50:16 UTC
I found this software (BiglyBT) utilizes SWT and offers a BSD installer that works. When checking the about dialog after installation on FreeBSD the SWT version is given thusly:

Java 1.8.0_131 (64 bit)
  Oracle Corporation
/usr/local/openjdk8/jre

SWT v4623, gtk/2.24.31
FreeBSD v11.1-STABLE, amd64 (64 bit)
B1.0.0.0/4 az3

Perhaps this can help someone. 

https://github.com/BiglySoftware/BiglyBT/releases
Comment 3 Keren Sky 2017-08-03 23:52:58 UTC
(In reply to Keren Sky from comment #2)
 Also in terminal window we see after launching:

Starting BiglyBT...
Suitable java version found [java = openjdk 1.8.0_131]
Using swt/swt-bsd.jar v4.623
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2017-08-06 04:37:02 UTC
This port does not currently have a maintainer. Any patches/testing that can be provided will help substantially to progress the issue and would be appreciated. 

Is the x11-toolkits/swt port also out-of-date? If so, perhaps that port should be updated to the latest release, and the swt-devel port deleted
Comment 5 bsd 2017-08-15 17:34:02 UTC
(In reply to Kubilay Kocak from comment #4)

I am not knowledgeable enough to submit a patch, but could I test or help in other ways?

x11-toolkits/swt is even more outdated, being at version 3.5.2_4 

http://portsmon.freebsd.org/portoverview.py?category=x11-toolkits&portname=swt
Comment 6 vali gholami 2017-11-26 20:54:09 UTC
MARKED AS SPAM
Comment 7 bsd 2018-02-26 13:15:28 UTC
I got Bugzilla's request to act on this ticket, but, as I said above, I am not knowledgeable enough to submit a patch.

I could I test or help in other ways.

x11-toolkits/swt is even more outdated, being at version 3.5.2_4 

http://portsmon.freebsd.org/portoverview.py?category=x11-toolkits&portname=swt

Being x11-toolkits/swt port also out-of-date, that port should perhaps be updated to the latest release, and the swt-devel port deleted.
Comment 8 Walter Schwarzenfeld freebsd_triage 2018-02-26 13:22:14 UTC
The website states:
The latest Python updated failed. Repairs are in progress 20171025

Do you have a local copy of the patch and could attach it?
Comment 9 bsd 2018-02-26 13:32:42 UTC
No, sorry, I do not have a patch.

Some information can be found here, not sure if useful:
https://www.freshports.org/x11-toolkits/swt-devel/
Comment 10 bsd 2018-03-05 09:22:52 UTC
This ticket does not nned to relate to third party apps.

The main point is simply that swt, and swt-devel are out of date

Latest version is 4.7.2 (30 November 2017), as reported by official page: http://download.eclipse.org/eclipse/downloads/
Comment 11 Thomas Merkel 2018-06-28 07:54:16 UTC
Not sure if bugs are linked somehow but I've updated to the latest swt version based on the following ports changes: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=229360
Comment 12 bsd 2018-06-28 08:04:37 UTC
(In reply to Thomas Merkel from comment #11)

Thank you, I believe it is related, as the latest version will solve the issue.
Comment 13 Walter Schwarzenfeld freebsd_triage 2019-08-09 10:26:49 UTC
swt has version  4.7.3a (swt-devel 3.7.1 ??). 

Is this still relevant.

I think swt-devel should either updated if there is a newer version or removed.
Comment 14 Thomas Merkel 2019-08-11 10:25:45 UTC
From my point of view swt-devel could be removed from the ports tree?
Comment 15 Walter Schwarzenfeld freebsd_triage 2019-08-11 11:10:07 UTC
Overlooked swt-devel is still used by three ports. The rest here is solved, so I close here with overcome.
Comment 16 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-11 11:23:54 UTC
x11-toolkits/swt-devel is currently unmaintained, and has a version < (less than) x11-toolkits/swt.

Ports currently dependent on x11-toolkits/swt-devel:

audio/tuxguitar (yuri@)
graphics/jogamp-jogl (makc@)
net-p2p/vuze (unmaintained)

Ask maintainers of those ports whether the dependency can be switched to x11-toolkits/swt so as to deprecate and delete x11-toolkits/swt-devel
Comment 17 Walter Schwarzenfeld freebsd_triage 2019-08-11 11:43:19 UTC
TuxGuitar needs updated to 1.5.0 (port have now 1.2).
Vuze needs updated to 5760 (port have now 5740).
jogamp-jogl needs updated to 2.4.0 (port have now 2.2.2).
Comment 18 Walter Schwarzenfeld freebsd_triage 2019-08-11 11:53:05 UTC
For jogamp-jogl there is an update bug #225058 to 2.3.2.
Comment 19 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-11 11:56:47 UTC
(In reply to Walter Schwarzenfeld from comment #17)

To clarify, are those versions listed the versions required to support using x11-toolkits/swt (currently 4.7.3.a) ?
Comment 20 Walter Schwarzenfeld freebsd_triage 2019-08-11 12:09:40 UTC
I don't know. I don't find anything about it on Sourceforge for vuze and tuxguitar and 

also  nothing for jogamp-jogl:
https://jogamp.org/jogl/doc/HowToBuild.html
Comment 21 commit-hook freebsd_committer 2019-08-12 23:28:50 UTC
A commit references this bug:

Author: makc
Date: Mon Aug 12 23:28:42 UTC 2019
New revision: 508801
URL: https://svnweb.freebsd.org/changeset/ports/508801

Log:
  graphics/jogamp-jogl:
  - Switch to x11-toolkits/swt which is newer than swt-devel port

  PR:	219186

Changes:
  head/graphics/jogamp-jogl/Makefile
  head/graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml
Comment 22 Max Brazhnikov freebsd_committer 2019-08-12 23:34:03 UTC
graphics/jogamp-jogl is fixed now.
Comment 23 Walter Schwarzenfeld freebsd_triage 2019-08-13 03:56:28 UTC
Trying to build or update vuze:

It does build with swt and swt-devel. But it does not start: "java: error: no suitable JavaVMs found"
I think this is caused by a wrong build.xml.
Comment 24 Walter Schwarzenfeld freebsd_triage 2019-08-13 03:57:08 UTC
Forgot the current version in the port tree of vuze also does not start.
Comment 25 Walter Schwarzenfeld freebsd_triage 2019-08-13 04:13:27 UTC
I think we can remove swt-devel.
Comment 26 Max Brazhnikov freebsd_committer 2019-09-29 18:13:24 UTC
(In reply to Walter Schwarzenfeld from comment #23)
So it fails to run both with swt and swt-devel?
Comment 27 Max Brazhnikov freebsd_committer 2019-09-29 18:22:38 UTC
Created attachment 207940 [details]
patch for audio/tuxguitar

audio/tuxguitar needs testing
Comment 28 Yuri Victorovich freebsd_committer 2019-09-29 20:02:16 UTC
Approved, thanks!
Comment 29 Max Brazhnikov freebsd_committer 2019-09-30 20:10:59 UTC
Created attachment 207966 [details]
patch for java/openjfx8-devel

java/openjfx8-devel optionally depends on x11-toolkits/swt-devel. Switch to swt.
Comment 30 commit-hook freebsd_committer 2019-09-30 20:37:07 UTC
A commit references this bug:

Author: makc
Date: Mon Sep 30 20:36:38 UTC 2019
New revision: 513409
URL: https://svnweb.freebsd.org/changeset/ports/513409

Log:
  x11-toolkits/swt-devel:
  - Deprecate, x11-toolkits/swt has newer version. Schedule for removal in two weeks.

  PR:	219186

Changes:
  head/x11-toolkits/swt-devel/Makefile
Comment 31 commit-hook freebsd_committer 2019-09-30 20:38:09 UTC
A commit references this bug:

Author: makc
Date: Mon Sep 30 20:37:46 UTC 2019
New revision: 513410
URL: https://svnweb.freebsd.org/changeset/ports/513410

Log:
  net-p2p/vuze:
  - Switch from x11-toolkits/swt-devel to x11-toolkits/swt, which is newer
    than -devel variant.

  PR:		219186

Changes:
  head/net-p2p/vuze/Makefile
Comment 32 commit-hook freebsd_committer 2019-09-30 20:39:11 UTC
A commit references this bug:

Author: makc
Date: Mon Sep 30 20:38:20 UTC 2019
New revision: 513411
URL: https://svnweb.freebsd.org/changeset/ports/513411

Log:
  multimedia/iriverter:
  - Remove SWTDEVEL option. x11-toolkits/swt-devel is deprecated.

  PR:		219186

Changes:
  head/multimedia/iriverter/Makefile
Comment 33 commit-hook freebsd_committer 2019-09-30 20:39:14 UTC
A commit references this bug:

Author: makc
Date: Mon Sep 30 20:39:05 UTC 2019
New revision: 513413
URL: https://svnweb.freebsd.org/changeset/ports/513413

Log:
  audio/tuxguitar:
  - Switch from x11-toolkits/swt-devel to x11-toolkits/swt, which is newer
    than -devel variant.

  PR:		219186
  Approved by:	maintainer (yuri)

Changes:
  head/audio/tuxguitar/Makefile
  head/audio/tuxguitar/files/patch-TuxGuitar_build.properties
  head/audio/tuxguitar/files/tuxguitar.in
Comment 34 Tobias Kortkamp freebsd_committer 2019-10-01 06:34:39 UTC
Comment on attachment 207966 [details]
patch for java/openjfx8-devel

If it builds this is fine with me. Do not forget to bump PORTREVISION though.
Comment 35 Max Brazhnikov freebsd_committer 2019-10-01 08:39:33 UTC
(In reply to Tobias Kortkamp from comment #34)
I didn't touch PORTREVISION because SWT option is off by default. However I don't mind to bump it if you like.
Comment 36 Tobias Kortkamp freebsd_committer 2019-10-01 09:01:01 UTC
(In reply to Max Brazhnikov from comment #35)
If an option is off by default or not does not matter.  This myth
really needs to die.  You simply do not know who has SWT=on and
would run into (entirely preventable) problems because we do not
bump it.  PORTREVISION must always be bumped when there is a run
dependency change.  Also see the Porter's Handbook at [1] which
is fairly specific on the matter.

So yes, please do bump it. ;-)

[1] https://www.freebsd.org/doc/en/books/porters-handbook/makefile-naming.html#makefile-portrevision
Comment 37 commit-hook freebsd_committer 2019-10-01 09:19:16 UTC
A commit references this bug:

Author: makc
Date: Tue Oct  1 09:18:28 UTC 2019
New revision: 513467
URL: https://svnweb.freebsd.org/changeset/ports/513467

Log:
  java/openjfx8-devel:
  - Switch from x11-toolkits/swt-devel to x11-toolkits/swt, which is newer
    than -devel variant.

  PR:		219186
  Approved by:	maintainer (tobik)

Changes:
  head/java/openjfx8-devel/Makefile
  head/java/openjfx8-devel/files/patch-build.gradle
Comment 38 Max Brazhnikov freebsd_committer 2019-10-01 09:21:05 UTC
x11-toolkits/swt-devel is deprecated and will be removed in two weeks.