Bug 219214 - Synergy, Virtualbox, Mousecursor-Polling
Summary: Synergy, Virtualbox, Mousecursor-Polling
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: vbox
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-11 08:25 UTC by SF
Modified: 2017-05-15 03:04 UTC (History)
0 users

See Also:


Attachments
Terminal Debug Log, starts from the point of entering the screen with the mousecursor (265.66 KB, text/plain)
2017-05-11 08:25 UTC, SF
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description SF 2017-05-11 08:25:55 UTC
Created attachment 182506 [details]
Terminal Debug Log, starts from the point of entering the screen with the mousecursor

I've installed Virtualbox to have USB-Drivers for my USB-Devices, did plug an old USB 1.1 Hub to my Computer to force my devices into USB 1.1 mode and pass them to my VM. Drivers and Devices are working fine so far. Next was i did set up Synergy within an Virtualbox-Machine(win 8.1) as a Server and connected FreeBSD as a Client to it to have my mouse with full driver-support, this works completely fine except of the movements of the cursor.

Inside the VM i can move my mouse completely normally, all reactions are as they should be. If i go outside the VM with the Mouse-Cursor onto my FreeBSD-Desktop then the Mouse-Cursor acts very choppy. If i push any mousebuttons they react instantly and also the cursermovement starts without any delay, its just not the cursor updating as fast as it should be.

The debuglog from Terminal shows a Movement from left to the screen to right of the screen as fast as i can move the mouse.

To me this looks like there shouldn't be any choppy mouse-movements, it transmits alot of coordinates. The movement on the screen looked to me like the mouse was jumping from left to right of the screen over 3-4 positions. The Desktop-Environment is somehow skipping all those coordinates.

FreeBSD 11.0 with XFCE
Comment 1 SF 2017-05-11 08:30:06 UTC
I dont know how many people this affects within FreeBSD but i guess its not only me having problems with this. Just search the internet for this problem, many linux-users have/had this too with Synergy. I think something must be done from OS-Side to make it work because the client/server-connections appears to do what it shall do.