Bug 219486 - graphics/cimg: fails to build with lang/gcc6 or later on 10.*
Summary: graphics/cimg: fails to build with lang/gcc6 or later on 10.*
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thierry Thomas
URL:
Keywords:
Depends on: 221065
Blocks: 219275
  Show dependency treegraph
 
Reported: 2017-05-24 03:46 UTC by Jan Beich
Modified: 2017-07-30 14:21 UTC (History)
4 users (show)

See Also:
thierry: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-05-24 03:46:26 UTC
/usr/local/lib/libGraphicsMagick++.so: undefined reference to `operator delete(void*, unsigned long)'
c++: error: linker command failed with exit code 1 (use -v to see invocation)

http://package22.nyi.freebsd.org/data/103amd64-default-PR219275/2017-05-20_20h22m32s/logs/errors/cimg-1.7.9_5,3.log
http://package23.nyi.freebsd.org/data/103i386-default-PR219275/2017-05-20_20h22m29s/logs/errors/cimg-1.7.9_5,3.log
Comment 1 Thierry Thomas freebsd_committer 2017-06-08 19:39:46 UTC
The failure seems caused by graphics/GraphicsMagick: adding the maintainer of GraphicsMagick.

Sunpoet, any clue about this error?
Comment 2 Raphael Kubo da Costa freebsd_committer 2017-07-30 14:21:32 UTC
I believe this is fixed via bug 221065.