Bug 219544 - net/pacemaker: Update to 1.1.16
Summary: net/pacemaker: Update to 1.1.16
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jochen Neumeister
URL:
Keywords: needs-patch, needs-qa
Depends on: 219542
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-25 18:57 UTC by David Shane Holden
Modified: 2017-06-13 14:33 UTC (History)
2 users (show)

See Also:


Attachments
pacemaker-1.1.16.patch (26.44 KB, patch)
2017-05-25 18:57 UTC, David Shane Holden
no flags Details | Diff
pacemaker-1.1.16.patch (26.75 KB, patch)
2017-05-28 16:24 UTC, David Shane Holden
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Shane Holden 2017-05-25 18:57:30 UTC
Created attachment 182899 [details]
pacemaker-1.1.16.patch
Comment 1 Jochen Neumeister freebsd_committer 2017-05-28 12:09:21 UTC
Hi,

the patch doesn't work:

===> Staging rc.d startup script(s)
===========================================================================
====> Running Q/A tests (stage-qa)
Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'share/pacemaker/tests/pengine/regression.sh'
Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'share/pacemaker/tests/coverage.sh'
Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'share/pacemaker/tests/BasicSanity.sh'
Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'share/pacemaker/tests/cts/lxc_autogen.sh'
Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'share/pacemaker/tests/cts/cts'
Error: '/usr/bin/python' is an invalid shebang you need USES=shebangfix for 'share/pacemaker/tests/cts/CTSlab.py'
*** Error code 1

Stop.
make: stopped in /usr/ports/net/pacemaker
====>> Error: stage-qa failures detected

see: http://joneumbox.org/data/12amd64-ports/2017-05-28_14h05m24s/logs/errors/pacemaker-1.1.16.log
Comment 2 David Shane Holden 2017-05-28 16:24:19 UTC
Created attachment 183010 [details]
pacemaker-1.1.16.patch
Comment 3 Jochen Neumeister freebsd_committer 2017-05-29 10:30:07 UTC
Hi,

can you please fix this too?

/net/pacemaker % portlint -AC
WARN: Makefile: [51]: possible direct use of command "sh" found. use ${SH} instead.
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
FATAL: Makefile: DISTVERSIONPREFIX appears out-of-order.
FATAL: Makefile: order must be PORTNAME/PORTVERSION/DISTVERSIONPREFIX/DISTVERSION/DISTVERSIONSUFFIX/PORTREVISION/PORTEPOCH/CATEGORIES/MASTER_SITES/MASTER_SITE_SUBDIR/PROJECTHOST/PKGNAMEPREFIX/PKGNAMESUFFIX/DISTNAME/EXTRACT_SUFX/DISTFILES/DIST_SUBDIR/EXTRACT_ONLY.
WARN: Makefile: new ports should not set PORTREVISION.
WARN: Makefile: "LIB_DEPENDS" has to appear earlier.
WARN: Makefile: "BUILD_DEPENDS" has to appear earlier.
WARN: Makefile: "RUN_DEPENDS" has to appear earlier.
FATAL: /usr/home/joneum/dev/ports/net/pacemaker/distinfo: has no SIZE record for ClusterLabs-pacemaker-Pacemaker-1.1.14_GH0.tar.gz.
FATAL: /usr/home/joneum/dev/ports/net/pacemaker/distinfo: no checksum record for ClusterLabs-pacemaker-Pacemaker-1.1.14_GH0.tar.gz.
WARN: /usr/home/joneum/dev/ports/net/pacemaker/distinfo: no checksum records for all supported algorithms (SHA256) for ClusterLabs-pacemaker-Pacemaker-1.1.14_GH0.tar.gz.
4 fatal errors and 7 warnings found.
Comment 4 David Shane Holden 2017-05-29 14:33:27 UTC
When I run portlint the only warnings I get are about the use of sh and the $FreeBSD$ tag.  Your output shows portlint erring about not being able to find 1.1.14 in distinfo but that should have been patched out.
Comment 5 David Shane Holden 2017-06-06 18:33:49 UTC
I just wanted to follow up on this because I'm not sure if you're waiting on me for anything.  Your portlint output leads me to believe your ports tree got into a weird state and the patch didn't apply cleanly.  I just tested it against the latest svn checkout and below is the output.


$ svn patch ~/pacemaker-1.1.16.patch ; portlint -AC
U         Makefile
U         distinfo
D         files/patch-Makefile.common
U         files/patch-crmd_pengine.c
D         files/patch-crmd_throttle.c
D         files/patch-extra_resources_ping
D         files/patch-lib-common-utils.c
D         files/patch-lib-services-services_linux.c
A         files/patch-lrmd_Makefile.am
A         files/patch-mcp_Makefile.am
U         pkg-plist
WARN: Makefile: [51]: possible direct use of command "sh" found. use ${SH} instead.
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
0 fatal errors and 3 warnings found.
Comment 6 Torsten Zuehlsdorff freebsd_committer 2017-06-07 09:10:23 UTC
David, your patch is fine for portlint. I checked it!
Comment 7 commit-hook freebsd_committer 2017-06-13 14:32:48 UTC
A commit references this bug:

Author: joneum
Date: Tue Jun 13 14:32:23 UTC 2017
New revision: 443502
URL: https://svnweb.freebsd.org/changeset/ports/443502

Log:
  - net/pacemaker: Update from 1.1.14 to 1.1.16
  - Fix shebangs
  - Changelog: https://github.com/ClusterLabs/pacemaker/blob/master/ChangeLog

  PR:		219544
  Submitted by:	David Shane Holden (maintainer)
  Approved by:	miwi (mentor)
  Differential Revision:	https://reviews.freebsd.org/D11109

Changes:
  head/net/pacemaker/Makefile
  head/net/pacemaker/distinfo
  head/net/pacemaker/files/patch-Makefile.common
  head/net/pacemaker/files/patch-crmd_pengine.c
  head/net/pacemaker/files/patch-crmd_throttle.c
  head/net/pacemaker/files/patch-extra_resources_ping
  head/net/pacemaker/files/patch-lib-common-utils.c
  head/net/pacemaker/files/patch-lib-services-services_linux.c
  head/net/pacemaker/files/patch-lrmd_Makefile.am
  head/net/pacemaker/files/patch-mcp_Makefile.am
  head/net/pacemaker/pkg-plist
Comment 8 Jochen Neumeister freebsd_committer 2017-06-13 14:33:15 UTC
Committed, thanks :-)