Bug 219566 - [MAINTAINER] net/tigervnc: Update to 1.8.0
Summary: [MAINTAINER] net/tigervnc: Update to 1.8.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Carlos J. Puga Medina
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-05-26 09:18 UTC by Koichiro Iwao
Modified: 2017-05-26 23:05 UTC (History)
2 users (show)

See Also:


Attachments
patch (4.81 KB, text/plain)
2017-05-26 09:18 UTC, Koichiro Iwao
no flags Details
patch2 (2.98 KB, patch)
2017-05-26 13:58 UTC, Koichiro Iwao
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Koichiro Iwao freebsd_committer 2017-05-26 09:18:17 UTC
Created attachment 182925 [details]
patch

- Update to 1.8.0
- Remove CONFLICTS with vnc as net/vnc port no longer exists

https://github.com/TigerVNC/tigervnc/releases/tag/v1.8.0

Poudreire build succeeds fine for me (11.0-RELEASE-p8 jail).
Comment 1 Carlos J. Puga Medina freebsd_committer 2017-05-26 13:37:11 UTC
There are some warnings shown by 'portlint -ac' output.

WARN: Makefile: [0]: possible direct use of command "false" found. use ${FALSE} instead.
WARN: Makefile: [0]: possible direct use of command "python" found. use ${PYTHON_CMD} instead.
WARN: Makefile: "LIB_DEPENDS" has to appear earlier.
WARN: /usr/ports/net/tigervnc/files/patch-cmake_BuildPackages.cmake: patch was not generated using ``make makepatch''.  It is recommended to use ``make makepatch'' when you need to [re-]generate a patch to ensure proper patch format.
WARN: /usr/ports/net/tigervnc/files/patch-CMakeLists.txt: patch was not generated using ``make makepatch''.  It is recommended to use ``make makepatch'' when you need to [re-]generate a patch to ensure proper patch format.
WARN: /usr/ports/net/tigervnc/files/patch-unix_vncserver: patch was not generated using ``make makepatch''.  It is recommended to use ``make makepatch'' when you need to [re-]generate a patch to ensure proper patch format.
0 fatal errors and 6 warnings found.

Please, consider fixing them (you can skip the first 2 warnings) :)
Comment 2 Koichiro Iwao freebsd_committer 2017-05-26 13:58:37 UTC
Created attachment 182933 [details]
patch2

Please apply attached patch-patch.
Comment 3 commit-hook freebsd_committer 2017-05-26 23:00:20 UTC
A commit references this bug:

Author: cpm
Date: Fri May 26 22:59:53 UTC 2017
New revision: 441817
URL: https://svnweb.freebsd.org/changeset/ports/441817

Log:
  net/tigervnc: update to 1.8.0

  - Remove CONFLICST with vnc as net/vnc no longer exists
  - Pet portlint, move LIB_DEPENDS up and regenerate patches with make makepatch

  Changes: https://github.com/TigerVNC/tigervnc/releases/tag/v1.8.0

  PR:		219566
  Submitted by:	Koichiro IWAO <meta+ports@vmeta.jp> (maintainer)

Changes:
  head/net/tigervnc/Makefile
  head/net/tigervnc/distinfo
  head/net/tigervnc/files/patch-CMakeLists.txt
  head/net/tigervnc/files/patch-cmake_BuildPackages.cmake
  head/net/tigervnc/files/patch-unix_vncserver
  head/net/tigervnc/files/patch-unix_xserver118.patch
  head/net/tigervnc/pkg-plist
Comment 4 commit-hook freebsd_committer 2017-05-26 23:04:26 UTC
A commit references this bug:

Author: cpm
Date: Fri May 26 23:03:54 UTC 2017
New revision: 441818
URL: https://svnweb.freebsd.org/changeset/ports/441818

Log:
  - Mark tigervnc-devel ignore because no development version available right now
  - Remove CONFLICTS with vnc as net/vnc port no longer exists
  - Pet portlint, move LIB_DEPENDS up and regenerate patches with make makepatch

  PR:		219566
  Submitted by:	Koichiro IWAO <meta+ports@vmeta.jp> (maintainer)

Changes:
  head/net/tigervnc-devel/Makefile
  head/net/tigervnc-devel/files/patch-CMakeLists.txt
  head/net/tigervnc-devel/files/patch-cmake_BuildPackages.cmake
  head/net/tigervnc-devel/files/patch-unix_vncserver
Comment 5 Carlos J. Puga Medina freebsd_committer 2017-05-26 23:05:50 UTC
Committed!

Thanks