Bug 219603 - chinese/ibus-pinyin: Fails to build: cannot find input file: `po/Makefile.in.in'
Summary: chinese/ibus-pinyin: Fails to build: cannot find input file: `po/Makefile.in.in'
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-27 20:52 UTC by Yuri Victorovich
Modified: 2018-01-10 00:00 UTC (History)
1 user (show)

See Also:
henry.hu.sh: maintainer-feedback+


Attachments
config.log (107.47 KB, text/plain)
2017-05-29 04:33 UTC, Yuri Victorovich
no flags Details
remove nls option (897 bytes, patch)
2017-09-10 03:42 UTC, Henry Hu
no flags Details | Diff
remove NLS option (1.78 KB, patch)
2017-09-11 03:35 UTC, Henry Hu
henry.hu.sh: maintainer-approval+
Details | Diff
patch to allow building without NLS (1022 bytes, patch)
2017-12-26 05:21 UTC, Henry Hu
henry.hu.sh: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2017-05-27 20:52:29 UTC
checking for LUA... no
checking that generated files are newer than configure... done
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: error: cannot find input file: `po/Makefile.in.in'
===>  Script "configure" failed unexpectedly.
Please report the problem to henry.hu.sh@gmail.com [maintainer] and attach
the "/usr/ports/chinese/ibus-pinyin/work/ibus-pinyin-1.5.0/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1
Comment 1 Henry Hu 2017-05-29 01:25:53 UTC
There might be something wrong with your intltool.
Please attach the full config.log. Also, if there is any error printed during configuration process, please paste them here.
Comment 2 Yuri Victorovich freebsd_committer 2017-05-29 04:33:43 UTC
Created attachment 183025 [details]
config.log

checking for LUA... no
checking that generated files are newer than configure... done
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: error: cannot find input file: `po/Makefile.in.in'
===>  Script "configure" failed unexpectedly.
Please report the problem to henry.hu.sh@gmail.com [maintainer] and attach
the "/usr/ports/chinese/ibus-pinyin/work/ibus-pinyin-1.5.0/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1
Comment 3 Henry Hu 2017-05-29 05:26:37 UTC
The failure is caused by --disable-nls.
I'm still investigating why this does not work.
It seems like that even with --disable-nls, configure still sets USE_NLS to yes.
For now, you can enable the NLS option and it should compile.
Comment 4 Henry Hu 2017-05-29 23:14:12 UTC
I'm considering removing the NLS option and force it to be enabled.
It seems like that some part of the code, like data/Makefile.am, assumes that intltool is available. Thus, --disable-nls may not work.
As this project seems mostly unmaintained, I don't think that it would be fixed anytime soon if reported.
Is there any reason you want to build it with NLS disabled?
Comment 5 Yuri Victorovich freebsd_committer 2017-05-29 23:34:07 UTC
> Is there any reason you want to build it with NLS disabled?

I have NLS off in my setup in /etc/make.conf. No other reason than tring to minimize the disk space. Ideally NLS should work when applicable, but I am okay, go ahead and remove it if it is unfixable.
Comment 6 Henry Hu 2017-09-10 03:42:47 UTC
Created attachment 186218 [details]
remove nls option

This patch removes the NLS option. I think that it cannot be disabled.
Comment 7 Henry Hu 2017-09-11 03:35:45 UTC
Created attachment 186238 [details]
remove NLS option

Last patch failed to change the plist. This patch fixes it.
It passed poudriere.
Comment 8 Yuri Victorovich freebsd_committer 2017-12-20 01:48:55 UTC
Hi,

This might solve the problem:
> USE_GNOME=      intltool

Yuri
Comment 9 Henry Hu 2017-12-26 05:21:39 UTC
Created attachment 189106 [details]
patch to allow building without NLS

This patch keeps the NLS option, but makes the dependencies always required.
It seems like that USE_GNOME=intltool is not enough. USE=gettext is also required even if you do not build with NLS.
With this patch, when NLS is disabled, mo files are not installed.
Comment 10 Yuri Victorovich freebsd_committer 2017-12-26 05:42:26 UTC
(In reply to Henry Hu from comment #9)

Thank you, Henry.

Yuri
Comment 11 Yuri Victorovich freebsd_committer 2018-01-10 00:00:00 UTC
Committed.

Thank you, Henry!
Comment 12 commit-hook freebsd_committer 2018-01-10 00:00:53 UTC
A commit references this bug:

Author: yuri
Date: Tue Jan  9 23:59:56 UTC 2018
New revision: 458586
URL: https://svnweb.freebsd.org/changeset/ports/458586

Log:
  chinese/ibus-pinyin: Fixed build with NLS=off

  PR:		219603
  Submitted by:	Henry Hu <henry.hu.sh@gmail.com>
  Reported by:	yuri
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D13736

Changes:
  head/chinese/ibus-pinyin/Makefile