Bug 219633 - devel/qt5-qdoc: build fails due to __bss_start@Qt_5 and _edata@Qt_5 being multiply defined by qt5-core
Summary: devel/qt5-qdoc: build fails due to __bss_start@Qt_5 and _edata@Qt_5 being mul...
Status: Closed DUPLICATE of bug 218187
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-29 13:12 UTC by jau
Modified: 2017-05-29 13:33 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jau 2017-05-29 13:12:13 UTC
See below an example how the build fails on FreeBSD-10.3-stable on amd64...
The multiple definitions come from qt5-core, but other than that I don't
have the foggiest idea why this happens.


--- ../../bin/qdoc ---
c++ -Wl,--as-needed -fstack-protector -Wl,--gc-sections -pthread -Wl,-rpath,/usr/local/lib/qt5 -o ../../bin/qdoc .obj/atom.o  .obj/codechunk.o  .obj/codemarker.o  .obj/codeparser.o  .obj/config.o  .obj/cppcodemarker.o  .obj/cppcodeparser.o  .obj/doc.o  .obj/editdistance.o  .obj/generator.o  .obj/helpprojectwriter.o  .obj/htmlgenerator.o  .obj/location.o  .obj/main.o  .obj/node.o  .obj/openedlist.o  .obj/plaincodemarker.o  .obj/puredocparser.o  .obj/qdocdatabase.o  .obj/qdoctagfiles.o  .obj/qdocindexfiles.o  .obj/quoter.o  .obj/separator.o  .obj/text.o  .obj/tokenizer.o  .obj/tree.o  .obj/yyindent.o  .obj/jscodemarker.o  .obj/qmlcodemarker.o  .obj/qmlcodeparser.o  .obj/qmlmarkupvisitor.o  .obj/qmlvisitor.o   -L/usr/ports/devel/qt5-qdoc/work/qttools-opensource-src-5.7.1/lib -L/usr/local/lib -L/usr/local/lib/qt5 -lQt5QmlDevTools -lQt5Core
/usr/local/lib/qt5/libQt5Core.so:(.data.rel.ro.local+0x27c28): multiple definition of `__bss_start@Qt_5'
/usr/local/lib/qt5/libQt5Core.so:(.data.rel.ro.local+0x27c28): first defined here
/usr/local/lib/qt5/libQt5Core.so:(.data.rel.ro.local+0x27c28): multiple definition of `_edata@Qt_5'
/usr/local/lib/qt5/libQt5Core.so:(.data.rel.ro.local+0x27c28): first defined here
/usr/local/lib/qt5/libQt5Core.so:(.data.rel.ro.local+0x2b3d8): multiple definition of `_end@Qt_5'
c++: error: linker command failed with exit code 1 (use -v to see invocation)
*** [../../bin/qdoc] Error code 1

make[1]: stopped in /usr/ports/devel/qt5-qdoc/work/qttools-opensource-src-5.7.1/src/qdoc
1 error

make[1]: stopped in /usr/ports/devel/qt5-qdoc/work/qttools-opensource-src-5.7.1/src/qdoc
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1
Comment 1 Tobias C. Berner freebsd_committer 2017-05-29 13:33:34 UTC

*** This bug has been marked as a duplicate of bug 218187 ***