Bug 219648 - devel/py-flake8: Add missing dependencies
Summary: devel/py-flake8: Add missing dependencies
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: William Grzybowski
URL:
Keywords: needs-patch, needs-qa
: 224043 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-30 00:48 UTC by Alan Somers
Modified: 2017-12-04 12:16 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (wg)
koobs: merge-quarterly?


Attachments
Patch (513 bytes, patch)
2017-12-02 07:45 UTC, Shin Fujishiro
snsinfu: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Somers freebsd_committer 2017-05-30 00:48:30 UTC
The py-flake8 port is missing some run dependencies that flake8 requires:
devel/py-configparser
devel/py-enum34
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2017-05-30 02:50:40 UTC
Both dependencies are conditional (as per setup.py:requires):

if sys.version_info < (3, 4):     requires.append("enum34")

if sys.version_info < (3, 2):     requires.append("configparser")
Comment 2 Shin Fujishiro 2017-12-02 07:45:39 UTC
Created attachment 188461 [details]
Patch

Add missing dependencies.

portlint: No error
testport: No error (11.1-RELEASE, amd64, py27 and py36 flavors)

Although portlint reports "no port directory" warnings caused by ${FLAVOR} in
RUN_DEPENDS, the port builds and installs successfully.
Comment 3 Jan Beich freebsd_committer 2017-12-02 23:56:27 UTC
*** Bug 224043 has been marked as a duplicate of this bug. ***
Comment 4 commit-hook freebsd_committer 2017-12-04 12:13:45 UTC
A commit references this bug:

Author: wg
Date: Mon Dec  4 12:12:58 UTC 2017
New revision: 455509
URL: https://svnweb.freebsd.org/changeset/ports/455509

Log:
  devel/py-flake8: add missing dependencies

  PR:		219648
  Submitted by:	asomers

Changes:
  head/devel/py-flake8/Makefile
Comment 5 William Grzybowski freebsd_committer 2017-12-04 12:16:47 UTC
thanks!