Bug 219658 - devel/py-pip: wrong reference of /nxb-bin/usr/bin/cc when building c packages
Summary: devel/py-pip: wrong reference of /nxb-bin/usr/bin/cc when building c packages
Status: Closed DUPLICATE of bug 208282
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Some People
Assignee: freebsd-python mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-30 15:57 UTC by Guangyuan Yang
Modified: 2017-05-31 14:24 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (python)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guangyuan Yang freebsd_committer 2017-05-30 15:57:32 UTC
It seems that FreeBSD uses some cross-compile tools on arm devices (and maybe other embedded platforms) which will cause build errors when building c packages (cffi as an example). References of cc is /nxb-bin/usr/bin/cc in /usr/local/lib/python2.7/_sysconfigdata.py

Log:
root@beaglebone:~ # pip install cffi
Collecting cffi
  Using cached cffi-1.10.0.tar.gz
    Complete output from command python setup.py egg_info:
    unable to execute '/nxb-bin/usr/bin/cc': No such file or directory
    unable to execute '/nxb-bin/usr/bin/cc': No such file or directory

        No working compiler found, or bogus compiler options
        passed to the compiler from Python's distutils module.
        See the error messages above.
        (If they are about -mno-fused-madd and you are on OS/X 10.8,
        see http://stackoverflow.com/questions/22313407/ .)

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-cIAYEn/cffi/

Temporary workaround:
sed -i '' 's/\/nxb-bin\/usr\/bin\/cc/\/usr\/bin\/cc/g' /usr/local/lib/python2.7/_sysconfigdata.py
Comment 1 mikael.urankar 2017-05-31 08:01:11 UTC
duplicate of bug #208282
Comment 2 Ed Maste freebsd_committer 2017-05-31 14:24:38 UTC

*** This bug has been marked as a duplicate of bug 208282 ***