Bug 219669 - cad/elmerfem: Update and make MPI an option
Summary: cad/elmerfem: Update and make MPI an option
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Pedro F. Giffuni
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-31 02:10 UTC by Pedro F. Giffuni
Modified: 2019-08-12 17:45 UTC (History)
1 user (show)

See Also:


Attachments
Update elmerfem to version 20170530 (2.46 KB, patch)
2017-05-31 02:10 UTC, Pedro F. Giffuni
no flags Details | Diff
Update elmerfem to version 20170601 (5.42 KB, patch)
2017-06-01 20:38 UTC, Pedro F. Giffuni
no flags Details | Diff
Update elmerfem to version 20170601 (5.43 KB, patch)
2017-06-02 01:53 UTC, Pedro F. Giffuni
no flags Details | Diff
Update elmerfem to version 20170703 (5.79 KB, patch)
2017-07-10 00:05 UTC, Pedro F. Giffuni
no flags Details | Diff
Update to version 4.3 (WIP) (6.50 KB, patch)
2019-08-11 16:44 UTC, Pedro F. Giffuni
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro F. Giffuni freebsd_committer 2017-05-31 02:10:29 UTC
Created attachment 183081 [details]
Update elmerfem to version 20170530

For those of us that don't have a setup with MPI just bring a serial version by default. MPI users now have to set an option.

Add a comment explaining why we need the shared version number in the port.

Update it yet again since I am here.

For the record, I tried to add options to enable OpenMP and to build elmergui without success.
Comment 1 Pedro F. Giffuni freebsd_committer 2017-05-31 02:12:36 UTC
(In reply to Pedro F. Giffuni from comment #0)
> Add a comment explaining why we need the shared version number in the port.

I meant "why we need the shared version number in the MPICH port dependency".
portlint complains about it but it can be safely ignored.
Comment 2 Pedro F. Giffuni freebsd_committer 2017-06-01 20:38:26 UTC
Created attachment 183139 [details]
Update elmerfem to version 20170601

Use cmake:outsource to build out of the src tree. Regular updates while here.
Comment 3 Pedro F. Giffuni freebsd_committer 2017-06-02 01:53:51 UTC
Created attachment 183141 [details]
Update elmerfem to version 20170601

Minor update in a comment (using OpenMP in the serial case is WIP).
Comment 4 Pedro F. Giffuni freebsd_committer 2017-07-10 00:05:10 UTC
Created attachment 184214 [details]
Update elmerfem to version 20170703
Comment 5 Pedro F. Giffuni freebsd_committer 2017-11-28 20:41:58 UTC
THis doesn't seem to build anymore here :(
Comment 6 Rene Ladan freebsd_committer 2019-08-11 13:45:12 UTC
Any news on this?
Comment 7 Rene Ladan freebsd_committer 2019-08-11 14:25:26 UTC
The current patch is broken, it does not apply on a clean tree and Makefile/distinfo disagree on the version number.
Comment 8 Pedro F. Giffuni freebsd_committer 2019-08-11 16:42:17 UTC
(In reply to Rene Ladan from comment #7)
Sorry I've been busy (for more than a year). The PR is completely outdated.

I started looking at it a few days ago and after fixing some CMake stuff:
https://github.com/ElmerCSC/elmerfem/issues/180

I still get errors, apparently it can't detect blas:

...
Linking Fortran executable cmTC_eb652
/usr/local/bin/cmake -E cmake_link_script CMakeFiles/cmTC_eb652.dir/link.txt --verbose=1
/usr/local/bin/gfortran9    -O -Wl,-rpath=/usr/local/lib/gcc9 -fPIC  CMakeFiles/cmTC_eb652.dir/testFortranCompiler.f.o  -o cmTC_eb652 -Wl,-rpath,/usr/local/lib /usr/local/lib/libblas.so 
/usr/local/bin/ld: CMakeFiles/cmTC_eb652.dir/testFortranCompiler.f.o: in function `main':
testFortranCompiler.f:(.text+0x20): undefined reference to `cheev_'
collect2: error: ld returned 1 exit status
gmake[2]: *** [CMakeFiles/cmTC_eb652.dir/build.make:88: cmTC_eb652] Error 1
gmake[2]: Leaving directory '/usr/ports/cad/elmerfem/work/.build/CMakeFiles/CMakeTmp'
gmake[1]: *** [Makefile:121: cmTC_eb652/fast] Error 2
gmake[1]: Leaving directory '/usr/ports/cad/elmerfem/work/.build/CMakeFiles/CMakeTmp'
Comment 9 Pedro F. Giffuni freebsd_committer 2019-08-11 16:44:10 UTC
Created attachment 206442 [details]
Update to version 4.3 (WIP)

Leaving my WIP attempt to update for future reference :(.
Comment 10 Pedro F. Giffuni freebsd_committer 2019-08-11 16:47:20 UTC
Abandon: the patch was updated long ago so the original patch became irrelevant.
The port will require a renewed effort far beyond this PR.
Comment 11 Pedro F. Giffuni freebsd_committer 2019-08-11 17:03:05 UTC
(In reply to Pedro F. Giffuni from comment #8)
Actually the problem is that irt doesn't add the lapack depency here:
(configure) ..

--  ELMERLIB_RPATH_STRING 
CMake Error at fem/src/CMakeLists.txt:347 (ADD_DEPENDENCIES):
  Cannot add target-level dependencies to non-existent target
  "elmersolver_link".

  The add_dependencies works for top-level logical targets created by the
  add_executable, add_library, or add_custom_target commands.  If you want to
  add file-level dependencies see the DEPENDS option of the add_custom_target
  and add_custom_command commands.
...
Comment 12 Rene Ladan freebsd_committer 2019-08-12 17:45:29 UTC
I removed the port for now. Feel free to resurrect it when it is working again.