Bug 219690 - [PATCH] devel/storm: Update to 1.0.2
Summary: [PATCH] devel/storm: Update to 1.0.2
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-05-31 19:11 UTC by Mark Felder
Modified: 2021-03-15 16:31 UTC (History)
5 users (show)

See Also:
hsn: maintainer-feedback+


Attachments
storm 2.0 port (87.50 KB, application/x-tar)
2019-08-24 20:52 UTC, Radim Kolar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Felder freebsd_committer 2017-05-31 19:11:22 UTC
Opening a bug to track this formally. I contacted the maintainer a long time ago, but did not hear back on test results yet.


patch is here:

https://reviews.freebsd.org/D9355
Comment 1 Thomas Zander freebsd_committer 2017-08-12 15:26:28 UTC
This should qualify for maintainer timeout by now.
Comment 2 Martin Wilke freebsd_committer 2018-03-08 00:51:06 UTC
maintainer timeout
Comment 3 Radim Kolar 2018-07-21 19:53:04 UTC
I have FreeBSD 11 up and running, will take a look on it after i fix my other 2 currently broken ports
Comment 4 Radim Kolar 2019-08-24 20:52:22 UTC
Created attachment 206866 [details]
storm 2.0 port
Comment 5 Radim Kolar 2019-08-24 20:53:04 UTC
Here is storm 2.0 port. it doesnt work due to missing rocksdbjni.
Comment 6 daniel.engberg.lists 2020-03-20 08:03:04 UTC
Mark, can you have a look at this?
Comment 7 Mark Felder freebsd_committer 2020-08-21 14:56:15 UTC
(In reply to daniel.engberg.lists from comment #6)

Unfortunately I no longer use this software / have access to an ecosystem that requires it.
Comment 8 Dmitry Marakasov freebsd_committer 2021-02-16 12:14:31 UTC
Storm was removed from the ports collection because it was using unsupported version 2 of python. Attached storm 2.0 port requires python 2 as well so it cannot be added. Radim, if there's still any interest, the submission needs to be updated to address this (probably by updating to the latest version). If it requires additional software (rocksdbjni?) to work, it should be ported first.