Bug 219698 - graphics/linux-c7-glx-utils: glxgears won't run
Summary: graphics/linux-c7-glx-utils: glxgears won't run
Status: Closed DUPLICATE of bug 217901
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-emulation mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-01 02:46 UTC by Erik Nordstrøm
Modified: 2017-06-01 11:32 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (emulation)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Nordstrøm 2017-06-01 02:46:32 UTC
When I try to run /compat/linux/bin/glxgears, it says

    libGL error: No matching fbConfigs or visuals found
    libGL error: failed to load driver: swrast
    X Error:  BadValue
      Request Major code 153 (GLX)
      Request Minor code 3 ()
      Value 0x0
      Error Serial #35
      Current Serial #37

My environment is as follows:

FreeBSD 11.0 on a ThinkPad laptop with an Nvidia NVS 4200M GPU.

Have the linux and linux64 kernel modules loaded.

Installed binary package emulators/linux_base-c7

Built and installed x11/nvidia-driver, version 375.66, from ports.

Built and installed graphics/linux-c7-dri from ports.

Built and installed graphics/linux-c7-glx-utils from ports.

Tried to run /compat/linux/bin/glxgears error message as shown above.

Meanwhile, the regular FreeBSD ELF glxgears works fine.

Don't know if this issue stems from graphics/linux-c7-glx-utils, graphics/linux-c7-dri, x11/nvidia-driver or someplace else but reporting it for graphics/linux-c7-glx-utils since the symptom shows up when trying to run glxgears.

Temporary workarounds are welcome for me personally.
Comment 1 Tijl Coosemans freebsd_committer 2017-06-01 09:15:48 UTC
nvidia driver does not support linux64 (yet?).

*** This bug has been marked as a duplicate of bug 217901 ***
Comment 2 Erik Nordstrøm 2017-06-01 11:32:21 UTC
(In reply to Tijl Coosemans from comment #1)

Thanks for the info. I hope Nvidia will add support for linux64.