Bug 219781 - net/openldap24-server: fix build with LibreSSL
Summary: net/openldap24-server: fix build with LibreSSL
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Xin LI
URL:
Keywords:
: 219772 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-04 17:19 UTC by Pawel Pekala
Modified: 2017-06-05 14:53 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (delphij)


Attachments
LibreSSL build fix (2.81 KB, patch)
2017-06-04 17:19 UTC, Pawel Pekala
no flags Details | Diff
corrected-patch-libressl (2.56 KB, patch)
2017-06-04 22:25 UTC, w.schwarzenfeld
no flags Details | Diff
svn-diff-openldap24-server (3.16 KB, patch)
2017-06-04 22:41 UTC, w.schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pawel Pekala freebsd_committer 2017-06-04 17:19:56 UTC
Created attachment 183213 [details]
LibreSSL build fix

Recent update don't build with LibreSSL.
Comment 1 w.schwarzenfeld freebsd_triage 2017-06-04 22:25:16 UTC
Created attachment 183223 [details]
corrected-patch-libressl
Comment 2 w.schwarzenfeld freebsd_triage 2017-06-04 22:25:56 UTC
I correct the patch. The old patch patches a patch-libressl which does not
exist.
Comment 3 w.schwarzenfeld freebsd_triage 2017-06-04 22:31:10 UTC
I think it is better if you make a new patch you only post the patch itself or
you make a svn diff.
Comment 4 w.schwarzenfeld freebsd_triage 2017-06-04 22:41:31 UTC
Created attachment 183225 [details]
svn-diff-openldap24-server
Comment 5 Xin LI freebsd_committer 2017-06-05 04:21:44 UTC
(In reply to Pawel Pekala from comment #0)
Thanks! Could you please also submit an ITS ticket at: https://www.openldap.org/its/ ?
Comment 6 commit-hook freebsd_committer 2017-06-05 04:21:58 UTC
A commit references this bug:

Author: delphij
Date: Mon Jun  5 04:20:53 UTC 2017
New revision: 442605
URL: https://svnweb.freebsd.org/changeset/ports/442605

Log:
  Fix build with LibreSSL.

  PR:		219781
  Submitted by:	pawel

Changes:
  head/net/openldap24-server/files/patch-libressl
Comment 7 Xin LI freebsd_committer 2017-06-05 04:22:07 UTC
*** Bug 219772 has been marked as a duplicate of this bug. ***
Comment 8 Pawel Pekala freebsd_committer 2017-06-05 14:53:43 UTC
(In reply to Xin LI from comment #5)
Thanks, submitted upstream:

http://www.openldap.org/its/index.cgi/Incoming?id=8666;selectid=8666