Bug 219874 - lib/libc/tests/nss/gethostby_test is failing sporadically
Summary: lib/libc/tests/nss/gethostby_test is failing sporadically
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: tests (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-testing (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-08 22:18 UTC by Enji Cooper
Modified: 2019-01-24 07:58 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2017-06-08 22:18:47 UTC
I'm running into periodic issues with some of the subtestcases, in particular,
:getipnodebyname_getaddrinfo_ipv6, e.g.,

using getaddrinfo() to resolve localhost
using getaddrinfo() to resolve anoncvs.cirr.com
using getaddrinfo() to resolve anoncvs.netbsd.se
using getaddrinfo() to resolve antioche.antioche.eu.org
using getaddrinfo() to resolve centaurus.4web.cz
using getaddrinfo() to resolve ntp.math.ntnu.no
using getaddrinfo() to resolve console.netbsd.org
using getaddrinfo() to resolve cvs.netbsd.org
using getaddrinfo() to resolve cvsup.netbsd.se
using getaddrinfo() to resolve ftp.chg.ru
using getaddrinfo() to resolve ftp.estpak.ee
using getaddrinfo() to resolve ftp.fsn.hu
using getaddrinfo() to resolve ftp.funet.fi
using getaddrinfo() to resolve ftp.netbsd.org
using getaddrinfo() to resolve ftp.nluug.nl
using getaddrinfo() to resolve ftp.plig.net
using getaddrinfo() to resolve ftp.rrze.uni-erlangen.de
using getaddrinfo() to resolve ftp.xgate.co.kr
using getaddrinfo() to resolve gd.tuwien.ac.at
using getaddrinfo() to resolve gort.ludd.luth.se
using getaddrinfo() to resolve chat.freenode.net
not equal - one of he->h_addr_list couldn't be found
not ok - addrinfo and hostent are not equal

I'm trying to add more logging to determine why the issue is occurring, since
the current information is insufficient.

This has been seen on a Comcast consumer networked machine and multiple Dell EMC networked machines.

The issue might be flaky DNS resolved names/address, intermittent connection issues, or an issue with the resolver software. Not enough information is known at this time to point a specific finger at the root cause.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2018-01-08 04:14:26 UTC
For the following conditions
Product: Base System, Documentation Status: New, Open, In Progress, UNCONFIRMED 
Assignee: Former FreeBSD committer 

Reset to default assignee. Reset status to "Open".
Comment 2 Li-Wen Hsu freebsd_committer 2019-01-21 21:53:38 UTC
I do not see lib.libc.nss.gethostby_test.getipnodebyname_getaddrinfo_ipv6 fails on ci.freebsd.org for a long time.  I suggest close this ticket and reopen when it fails more often.
Comment 3 Li-Wen Hsu freebsd_committer 2019-01-24 07:58:00 UTC
This test case runs fine on the new CI infrastructure.