Bug 219938 - mail/mailscanner: fix execution
Summary: mail/mailscanner: fix execution
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Wen Heping
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-12 12:30 UTC by Piotr Kubaj
Modified: 2017-07-28 16:39 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (kkobb)


Attachments
1 (15.36 KB, patch)
2017-06-12 12:30 UTC, Piotr Kubaj
no flags Details | Diff
patch (16.18 KB, patch)
2017-06-16 12:41 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2017-06-12 12:30:16 UTC
Created attachment 183426 [details]
1

Turns out I have sent a previous version of the patch for the update, which assumes / prefix. This patch updates the paths and bumps PORTREVISION.

This is patch includes the changes which I use on 11.1-PRERELEASE. I have also verified the port to build on 10.3-RELEASE.

Sorry for the breakage, I tried to react fast :)
Comment 1 Wen Heping freebsd_committer 2017-06-15 00:03:37 UTC
(In reply to Piotr Kubaj from comment #0)
Hi,

Would you have a look of this PR:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219990

Thanks !

wen
Comment 2 Piotr Kubaj freebsd_committer 2017-06-16 12:41:31 UTC
Created attachment 183531 [details]
patch

Corrected patch to not remove user's configuration.
Comment 3 Chris Rees freebsd_committer 2017-07-28 16:29:26 UTC
I've fixed it with my own work this afternoon, mostly reverting the changes.  If you're going to make changes like this, please ensure that you actually test run the port as well as build it.

I've not got time to merge your fixes in, sorry, but if you want them put in then feel free to send the patch to me and I'll review (I maintained the port before Kevin).

Cheers!

Chris
Comment 4 commit-hook freebsd_committer 2017-07-28 16:39:33 UTC
A commit references this bug:

Author: crees
Date: Fri Jul 28 16:39:23 UTC 2017
New revision: 446838
URL: https://svnweb.freebsd.org/changeset/ports/446838

Log:
  Partially revert the previous update.

  No longer clobber user's configuration.

  Fixup most pathnames, works for me now (tm)

  PR:		ports/217142
  PR:		ports/219938
  PR:		ports/219990

Changes:
  head/mail/mailscanner/Makefile
  head/mail/mailscanner/distinfo
  head/mail/mailscanner/pkg-plist