Bug 219982 - [exp-run] Update graphics/netpbm to 10.80.00
Summary: [exp-run] Update graphics/netpbm to 10.80.00
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-14 09:33 UTC by Tobias Kortkamp
Modified: 2017-10-06 11:19 UTC (History)
0 users

See Also:
antoine: exp-run+


Attachments
netpbm.diff (122.46 KB, patch)
2017-06-14 09:33 UTC, Tobias Kortkamp
no flags Details | Diff
netpbm2.diff (123.21 KB, patch)
2017-06-15 10:20 UTC, Tobias Kortkamp
no flags Details | Diff
netpbm3.diff (117.24 KB, patch)
2017-07-10 22:20 UTC, Tobias Kortkamp
no flags Details | Diff
netpbm.diff (117.29 KB, patch)
2017-09-30 21:55 UTC, Tobias Kortkamp
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2017-06-14 09:33:45 UTC
Created attachment 183475 [details]
netpbm.diff

[exp-run] Update graphics/netpbm to 10.78.05

I'd like to request an exp-run for the update.

Netpbm headers have been moved, and the version jump is relatively
large so it might break things (https://reviews.freebsd.org/D11157).

This includes a change to Uses/ghostscript.mk to allow adding
ghostscript to TEST_DEPENDS which graphics/netpbm now uses
(https://reviews.freebsd.org/D11114).
Comment 1 Antoine Brodin freebsd_committer 2017-06-15 07:34:57 UTC
astro/xplanet  no longer links against libnetpbm.so  after the upgrade
Comment 2 Tobias Kortkamp freebsd_committer 2017-06-15 10:20:00 UTC
Created attachment 183494 [details]
netpbm2.diff

(In reply to Antoine Brodin from comment #1)
Thanks.  I've added a fix to the patch and xplanet should link with libnetpbm now.
Comment 3 Antoine Brodin freebsd_committer 2017-06-16 19:07:40 UTC
astro/astrometry fails to patch
Comment 4 Antoine Brodin freebsd_committer 2017-06-16 19:08:05 UTC
sed: util/c.py: in-place editing only works for regular files
Comment 5 Tobias Kortkamp freebsd_committer 2017-06-20 07:33:19 UTC
(In reply to Antoine Brodin from comment #4)
This doesn't seem to be a problem with the netpbm update.  See for example
https://lists.freebsd.org/pipermail/freebsd-pkg-fallout/Week-of-Mon-20170619/488813.html

I've proposed a fix here for it: https://reviews.freebsd.org/D11242
Comment 6 commit-hook freebsd_committer 2017-06-30 15:05:49 UTC
A commit references this bug:

Author: tobik
Date: Fri Jun 30 15:05:05 UTC 2017
New revision: 444759
URL: https://svnweb.freebsd.org/changeset/ports/444759

Log:
  Fix build on 12.0-CURRENT

  Exclude util/c.py (a symlink to util/util.py) from SHEBANG_FILES.

  The build currently fails in the patch phase with:

  sed: util/c.py: in-place editing only works for regular files

  This seems to be caused by base r313277.

  While here also simplify RUN_DEPENDS.

  PR:		219982
  Reported by:	antoine, pkg-fallout
  Approved by:	mat (mentor)
  Differential Revision:	https://reviews.freebsd.org/D11242

Changes:
  head/astro/astrometry/Makefile
Comment 7 Tobias Kortkamp freebsd_committer 2017-07-10 22:20:51 UTC
Created attachment 184245 [details]
netpbm3.diff
Comment 8 Tobias Kortkamp freebsd_committer 2017-07-11 13:25:46 UTC
netpbm3.diff contains an update to netpbm 10.79.02.  All other issues that came
up should be fixed now too.  Is the exp-run ok now?
Comment 9 Tobias Kortkamp freebsd_committer 2017-09-30 21:55:18 UTC
Created attachment 186820 [details]
netpbm.diff

Update to netpbm 10.80.00

Can someone please (with a cherry on top) confirm that this is ok to commit?
Comment 10 Antoine Brodin freebsd_committer 2017-10-04 21:55:10 UTC
The ghostcript changes look unrelated
Comment 11 Antoine Brodin freebsd_committer 2017-10-04 21:58:11 UTC
(In reply to Antoine Brodin from comment #10)
or not, it is related
Comment 12 Antoine Brodin freebsd_committer 2017-10-06 07:09:19 UTC
Exp-run looks fine.
Comment 13 commit-hook freebsd_committer 2017-10-06 11:13:51 UTC
A commit references this bug:

Author: tobik
Date: Fri Oct  6 11:13:06 UTC 2017
New revision: 451376
URL: https://svnweb.freebsd.org/changeset/ports/451376

Log:
  Enable depending on Ghostscript in the test phase

  PR:		219982
  Reviewed by:	mat
  Exp-run by:	antoine
  Differential Revision:	https://reviews.freebsd.org/D11114

Changes:
  head/Mk/Uses/ghostscript.mk
Comment 14 commit-hook freebsd_committer 2017-10-06 11:18:57 UTC
A commit references this bug:

Author: tobik
Date: Fri Oct  6 11:18:36 UTC 2017
New revision: 451378
URL: https://svnweb.freebsd.org/changeset/ports/451378

Log:
  graphics/netpbm: Update to 10.80.00

  - This moves netpbm to the advanced release series, which brings the
    port closer to what is available on OpenBSD, Fedora, Arch Linux,
    openSUSE, etc. and will let us get rid of patches for supporting
    newer libpng versions.
  - The advanced release series is only available via an SVN checkout.
    Add two maintenance targets netpbm-version-check and netpbm-fetch
    to make fetching them easier.  To generate release tarballs the sources
    are then tagged and committed to https://github.com/t6/netpbm
  - Add STATIC option for linking all programs statically to allow running them
    in small chroots
  - Add option to disable adding a Perl run dependency.  Only a fraction
    of all programs need it.  Some are compatibility shims for newer
    programs which should be used instead.  The following programs require
    Perl: pamfixtrunc pbmtox10bm pgmcrater pnmflip pnmquant pnmquantall ppmfade
    ppmquant ppmrainbow ppmshadow
  - Disable building svgtopam by default.  It's the only program that
    requires libxml2 and is obsolete according to the author.
  - Install manpages by default
  - Allow running of the test suite via `make test`
  - Headers have been moved to ${LOCALBASE}/include/netpbm.  Fix ports
    that expect them to be in ${LOCALBASE}/include

  Changes:	https://raw.githubusercontent.com/t6/netpbm/v10.80.00/doc/HISTORY
  PR:		219982
  Reviewed by:	mat
  Exp-run by:	antoine
  Differential Revision:	https://reviews.freebsd.org/D11157

Changes:
  head/astro/xplanet/Makefile
  head/graphics/netpbm/Makefile
  head/graphics/netpbm/distinfo
  head/graphics/netpbm/files/Makefile.config.FreeBSD
  head/graphics/netpbm/files/config.mk
  head/graphics/netpbm/files/patch-GNUmakefile
  head/graphics/netpbm/files/patch-Makefile.common
  head/graphics/netpbm/files/patch-jpeg.c
  head/graphics/netpbm/files/patch-lib-Makefile
  head/graphics/netpbm/files/patch-lib-libpbm3.c
  head/graphics/netpbm/files/patch-lib-libpm.c
  head/graphics/netpbm/files/patch-lib-libsystem.c
  head/graphics/netpbm/files/patch-lib-util-pm_c_util.h
  head/graphics/netpbm/files/patch-lib_libpm.c
  head/graphics/netpbm/files/patch-pamrgbatopng.c
  head/graphics/netpbm/files/patch-pm_config.in.h
  head/graphics/netpbm/files/patch-pngtopnm.c
  head/graphics/netpbm/files/patch-pngtxt.c
  head/graphics/netpbm/files/patch-pngtxt.h
  head/graphics/netpbm/files/patch-pnmtopng.c
  head/graphics/netpbm/files/patch-ppmquantall
  head/graphics/netpbm/files/patch-ppmquantall.csh
  head/graphics/netpbm/files/patch-ppmtompeg-Makefile
  head/graphics/netpbm/pkg-descr
  head/graphics/netpbm/pkg-plist
  head/graphics/ppminfo/Makefile
  head/graphics/ppminfo/files/
  head/graphics/ppminfo/files/patch-pi.c
  head/graphics/tumble/Makefile
  head/graphics/urt/Makefile
  head/multimedia/subtitleripper/Makefile
  head/palm/imgvtopgm/Makefile
  head/palm/ppmtoTbmp/Makefile
Comment 15 Tobias Kortkamp freebsd_committer 2017-10-06 11:19:59 UTC
(In reply to Antoine Brodin from comment #12)
Thank you very much Antoine!