Bug 219990 - mail/mailscanner: recent update appears to severely break existing 4.x installations
Summary: mail/mailscanner: recent update appears to severely break existing 4.x instal...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Wen Heping
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-14 16:47 UTC by tundra
Modified: 2017-07-28 17:02 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (kkobb)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tundra 2017-06-14 16:47:36 UTC
The recent update to MailScaner 5.0.3 appears to severely break existing 4.x installations in the following ways:

- It does not properly reconstitute the MailScaner.conf file as did previous versions.

- It appears to be configured for the Linux standard install/configure dir tree, not the one long used in FreeBSD.

- The 'mailscanner' executable is not getting installed anywhere/the expected places, and this breaks the various service rc files completely.

- Even if we provide  a symlink - MailScanner -> mailscanner, the startup fails because the new executable complains that it cannot find the perl antiword module.

We've judged this be completely unusable at this time and have failed back to 4.85 as our production workaround.
Comment 1 Wen Heping freebsd_committer 2017-06-14 23:58:17 UTC
Would you try this patch :
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219938

I shall contact submitter for more fix.

Thanks !

wen
Comment 2 Piotr Kubaj freebsd_committer 2017-06-16 12:40:38 UTC
(In reply to Wen Heping from comment #1)
This is exactly the bug I reported - I have sent previously the previous patch which was WIP and was by accident committed. It was a combined mistake of mine and the committer.

The patch I provided in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219938 is fine, but it still removes the user's conf.

I will send in a moment the patch which seems 100% correct in the original PR (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219938) to not create additional confusion, please test it.
Comment 3 Chris Rees freebsd_committer 2017-07-28 16:30:11 UTC
I've fixed it with my own work this afternoon, mostly reverting the changes.  If you're going to make changes like this, please ensure that you actually test run the port as well as build it.

I've not got time to merge your fixes in, sorry, but if you want them put in then feel free to send the patch to me and I'll review (I maintained the port before Kevin).

To the OP, this problem should now be sorted, but there may be a few remaining path issues you may notice-- please let me know if you find them.

Cheers!

Chris
Comment 4 commit-hook freebsd_committer 2017-07-28 16:39:35 UTC
A commit references this bug:

Author: crees
Date: Fri Jul 28 16:39:23 UTC 2017
New revision: 446838
URL: https://svnweb.freebsd.org/changeset/ports/446838

Log:
  Partially revert the previous update.

  No longer clobber user's configuration.

  Fixup most pathnames, works for me now (tm)

  PR:		ports/217142
  PR:		ports/219938
  PR:		ports/219990

Changes:
  head/mail/mailscanner/Makefile
  head/mail/mailscanner/distinfo
  head/mail/mailscanner/pkg-plist
Comment 5 Piotr Kubaj freebsd_committer 2017-07-28 16:46:30 UTC
(In reply to Chris Rees from comment #3)
I did verify it, but then by accident sent the older version of the patch.

Still, I sent another PR with corrected patch day after it had been committed, which was over a month ago. That version has worked for months for me.
Comment 6 Chris Rees freebsd_committer 2017-07-28 17:02:14 UTC
I see you did, which should have gone in much quicker than that, so sorry you had to wait.