Bug 219993 - devel/py-twisted: missing hyperlink dependency
Summary: devel/py-twisted: missing hyperlink dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
: 220061 220120 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-14 19:03 UTC by Christian Sturm
Modified: 2017-06-19 14:12 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (grembo)


Attachments
buildbot-www poudriere log (21.50 KB, text/plain)
2017-06-17 08:34 UTC, Christian Sturm
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Sturm 2017-06-14 19:03:26 UTC
This port wants to install hyperlink in the configure phase, which poudriere doesn't allow.
Comment 1 Alan Somers freebsd_committer 2017-06-17 04:37:09 UTC
I can't reproduce this.  Could you please attach your poudriere log demonstrating the problem?
Comment 2 Christian Sturm 2017-06-17 08:34:31 UTC
Created attachment 183565 [details]
buildbot-www poudriere log

It seems like in the configure phase it tries to fetch hyperlink, which fails because poudriere disables network access.
Comment 3 Alan Somers freebsd_committer 2017-06-17 14:27:14 UTC
I don't see the word "hyperlink" anywhere in buildbot-www's distfiles, nor can I find that reference anywhere in /usr/local/lib/python2.7.  Do you have any modifications in your ports tree for either buildbot-www or buildbot-pkg ?  If not, then you probably have some other port build with non-default options.  You could try "grep -R hyperlink /usr/local/lib/python2.7" from within the jail to find the culprit.
Comment 4 Christian Sturm 2017-06-17 15:32:04 UTC
hyperlink is being pulled in by Twisted[1] it seems. I am not sure why it isn't a dependency of the port though and doesn't exist in the ports tree at all.


[1] https://github.com/twisted/twisted/blob/twisted-17.5.0/src/twisted/python/_setup.py#L231
Comment 5 Alan Somers freebsd_committer 2017-06-17 16:59:06 UTC
*** Bug 220061 has been marked as a duplicate of this bug. ***
Comment 6 Alan Somers freebsd_committer 2017-06-17 16:59:51 UTC
This was caused by the recent upgrade of py-twisted from 17.1.0 to 17.5.0, which introduced the hyperlink dependency.  Curiously, py-twisted itself builds fine, but none of its dependent ports do.
Comment 7 Alan Somers freebsd_committer 2017-06-17 17:01:27 UTC
sunpoet, the recent upgrade of py-twisted to 17.5.0 introduced a dependency on hyperlink.  Even though py-twisted builds just fine, its dependent ports don't.  Could you please add a port for the dependency?
Comment 8 commit-hook freebsd_committer 2017-06-18 02:57:37 UTC
A commit references this bug:

Author: sunpoet
Date: Sun Jun 18 02:56:44 UTC 2017
New revision: 443797
URL: https://svnweb.freebsd.org/changeset/ports/443797

Log:
  Fix *_DEPENDS

  - Bump PORTREVISION for dependency change

  PR:		219993 (based on)
  Submitted by:	Christian Sturm <reezer@reezer.org>

Changes:
  head/devel/py-twisted/Makefile
Comment 9 Sunpoet Po-Chuan Hsieh freebsd_committer 2017-06-18 04:15:02 UTC
Committed. Thanks!
Comment 10 Michael Gmelin freebsd_committer 2017-06-18 11:51:28 UTC
Thanks to all for taking care of this.
Comment 11 Mark Felder freebsd_committer 2017-06-19 14:12:21 UTC
*** Bug 220120 has been marked as a duplicate of this bug. ***