Bug 220034 - devel/ace: update to version 6.4.3 and takeover maintanership
Summary: devel/ace: update to version 6.4.3 and takeover maintanership
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Tobias C. Berner
URL:
Keywords: needs-qa
Depends on: 220179
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 08:18 UTC by Jov
Modified: 2017-06-28 15:50 UTC (History)
2 users (show)

See Also:


Attachments
ace-6.4.3.diff (10.24 KB, patch)
2017-06-16 08:18 UTC, Jov
no flags Details | Diff
ace-6.4.3.diff (3.20 KB, patch)
2017-06-28 07:59 UTC, Jov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jov 2017-06-16 08:18:03 UTC
Created attachment 183521 [details]
ace-6.4.3.diff

QA: poudriere testport passed on 11.0Ramd64
Comment 1 Jochen Neumeister freebsd_committer 2017-06-17 08:20:06 UTC
(In reply to Jov from comment #0)

Hi Jov :-)

I think removing %%SSL%%, %%QT4%% etc looks wrong can you please build with those options on ? Thank you :-)
Comment 2 Jov 2017-06-17 10:24:34 UTC
(In reply to Jochen Neumeister from comment #1)
SSL option already set on,the plist shows only the path changed.
QT4 option is off by default.I don't know why the origin version has %%QT4%% dir.I try to compile QT4 on,but build failed.I will investigate the problem.
Comment 3 Jov 2017-06-17 10:33:58 UTC
(In reply to Jochen Neumeister from comment #1)
FYI,the old 6.3.4 version also fail to build with QT4 option on.
Comment 4 Jochen Neumeister freebsd_committer 2017-06-20 21:46:18 UTC
Can you have a look why the build failes with qt on? This should be fixed.
Comment 5 Jov 2017-06-21 10:08:17 UTC
(In reply to Jochen Neumeister from comment #4)
Hi, I fixed the build failure for ace with qt4, please see the new PR for detail: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=220179

For this PR, I will fix the problem after the above PR committed.
Comment 6 Jov 2017-06-22 10:03:19 UTC
(In reply to Jov from comment #2)
all fixed. the problem is make makeplist auto generate pkg-plist remove the %%XX%% option prefix.Now fixed.
Comment 7 Tobias C. Berner freebsd_committer 2017-06-28 07:49:48 UTC
Hi there, 

can you update the patch? The plist still has the %%FOO%% missing.
Comment 8 Jov 2017-06-28 07:59:25 UTC
Created attachment 183877 [details]
ace-6.4.3.diff

fix pkg-plist
Comment 9 Jov 2017-06-28 08:01:37 UTC
(In reply to Tobias C. Berner from comment #7)
Please note, this patch against this PR: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=220179
Comment 10 commit-hook freebsd_committer 2017-06-28 15:47:56 UTC
A commit references this bug:

Author: tcberner
Date: Wed Jun 28 15:47:19 UTC 2017
New revision: 444599
URL: https://svnweb.freebsd.org/changeset/ports/444599

Log:
  devel/ace: update to version 6.4.3 and give maintanership

  PR:		220034
  Submitted by:	Jov <amutu@amutu.com>

Changes:
  head/devel/ace/Makefile
  head/devel/ace/distinfo
  head/devel/ace/pkg-plist
Comment 11 Tobias C. Berner freebsd_committer 2017-06-28 15:50:21 UTC
Thanks.