Bug 220109 - devel/py-qt5 compile failed with DEFAULT_VERSION+=python=3.5
Summary: devel/py-qt5 compile failed with DEFAULT_VERSION+=python=3.5
Status: Closed DUPLICATE of bug 219641
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-18 13:46 UTC by Martin Filla
Modified: 2017-09-25 13:07 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments
py-qt5_3.5_compile_failed (163.00 KB, text/plain)
2017-06-18 13:47 UTC, Martin Filla
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Filla 2017-06-18 13:46:40 UTC
Hello i compile devel/py-qt5-core with cd /usr/ports/devel/py-qt5 && sudo make PYTHON_VERSION=3.5 install clean

I have in /etc/make.conf DEFAULT_VERSIONS+= python=3.5 python3=3.5
but compile failed, compile log added.
Comment 1 Martin Filla 2017-06-18 13:47:47 UTC
Created attachment 183602 [details]
py-qt5_3.5_compile_failed

Added compile log
Comment 2 Martin Filla 2017-06-18 13:50:18 UTC
This is compilation fail.

===>   Registering installation for py35-qt5-core-5.7.1 as automatic
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/__pycache__/Qt.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/__pycache__/__init__.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Compiler/__pycache__/__init__.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Compiler/__pycache__/compiler.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Compiler/__pycache__/indenter.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Compiler/__pycache__/misc.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Compiler/__pycache__/proxy_metaclass.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Compiler/__pycache__/qobjectcreator.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Compiler/__pycache__/qtproxies.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Loader/__pycache__/__init__.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Loader/__pycache__/loader.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/Loader/__pycache__/qobjectcreator.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/__pycache__/__init__.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/__pycache__/driver.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/__pycache__/exceptions.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/__pycache__/icon_cache.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/__pycache__/objcreator.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/port_v3/__pycache__/__init__.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/port_v3/__pycache__/as_string.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/port_v3/__pycache__/ascii_upper.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/port_v3/__pycache__/proxy_base.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/port_v3/__pycache__/string_io.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/__pycache__/properties.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/__pycache__/pyuic.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/__pycache__/uiparser.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/widget-plugins/__pycache__/qaxcontainer.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/widget-plugins/__pycache__/qscintilla.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/widget-plugins/__pycache__/qtcharts.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/widget-plugins/__pycache__/qtprintsupport.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/widget-plugins/__pycache__/qtquickwidgets.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/widget-plugins/__pycache__/qtwebenginewidgets.opt-1.cpython-35.pyc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/py-qt5-core/work/stage/usr/local/lib/python3.5/site-packages/PyQt5/uic/widget-plugins/__pycache__/qtwebkit.opt-1.cpython-35.pyc:No such file or directory
*** Error code 74

Stop.
make[3]: stopped in /usr/ports/devel/py-qt5-core
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/py-qt5-core
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/py-qt5
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/py-qt5
Comment 3 Tobias C. Berner freebsd_committer 2017-09-25 13:07:55 UTC

*** This bug has been marked as a duplicate of bug 219641 ***