Bug 220167 - lib/libc/sys/setrlimit_test:setrlimit_memlock fails if RLIMIT_MEMLOCK not enforced
Summary: lib/libc/sys/setrlimit_test:setrlimit_memlock fails if RLIMIT_MEMLOCK not enf...
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: tests (show other bugs)
Version: 11.0-STABLE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-testing (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-20 18:34 UTC by Glen Barber
Modified: 2019-05-20 08:24 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Glen Barber freebsd_committer 2017-06-20 18:34:30 UTC
Perhaps a test for RLIMIT_MEMLOCK should be added to avoid the following false negative:

===> lib/libc/sys/setrlimit_test:setrlimit_memlock
Result:     failed: RLIMIT_MEMLOCK not enforced
Start time: 2017-06-20T16:24:44.396897Z
End time:   2017-06-20T16:24:44.406836Z
Duration:   0.010s

Metadata:
    allowed_architectures is empty
    allowed_platforms is empty
    description = Test setrlimit(2), RLIMIT_MEMLOCK
    has_cleanup = false
    is_exclusive = false
    required_configs is empty
    required_disk_space = 0
    required_files is empty
    required_memory = 0
    required_programs is empty
    required_user is empty
    timeout = 300
===> Failed tests
lib/libc/sys/setrlimit_test:setrlimit_memlock  ->  failed: RLIMIT_MEMLOCK not enforced  [0.010s]
===> Summary
Results read from /root/.kyua/store/results.usr_tests.20170620-155827-682012.db
Test cases: 1 total, 0 skipped, 0 expected failures, 0 broken, 1 failed
Start time: 2017-06-20T16:24:44.396897Z
End time:   2017-06-20T16:24:44.406836Z
Total time: 0.010s
Comment 1 Enji Cooper freebsd_committer 2017-06-20 19:43:09 UTC
How did you run this test (as root or as non-root)?
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2018-01-08 04:14:28 UTC
For the following conditions
Product: Base System, Documentation Status: New, Open, In Progress, UNCONFIRMED 
Assignee: Former FreeBSD committer 

Reset to default assignee. Reset status to "Open".
Comment 3 Mark Johnston freebsd_committer 2019-05-13 17:00:10 UTC
Is this PR still relevant?
Comment 4 Enji Cooper freebsd_committer 2019-05-15 00:48:35 UTC
(In reply to Mark Johnston from comment #3)

I’m not sure. I’ll investigate this when I return next Monday (reminder’s on my calendar).
Comment 5 Enji Cooper freebsd_committer 2019-05-20 08:24:25 UTC
This code is currently greenlit on ^/head. Closing the bug with "Unable to Reproduce".