Bug 220196 - [PATCH] textproc/groff: pkg-plist incorrect constraints for webpage-17
Summary: [PATCH] textproc/groff: pkg-plist incorrect constraints for webpage-17
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Baptiste Daroussin
URL:
Keywords: patch
: 220856 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-21 22:36 UTC by Phil Pennock
Modified: 2017-10-02 11:07 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (bapt)


Attachments
fix textproc/groff pkg-plist for webpage-17.html (785 bytes, patch)
2017-06-21 22:36 UTC, Phil Pennock
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Pennock 2017-06-21 22:36:57 UTC
Created attachment 183691 [details]
fix textproc/groff pkg-plist for webpage-17.html

Commit 722784c054 added webpage-17.html as an installable file, but missing the `%%HTMLDOCS%%` constraint.  In my (presumably typical) non-X11 Poudriere build, that variable substitution ends up as `@comment `, which prevents install of those files.

Thus at present, groff won't package (for me) under Poudriere.

Trivial patch-fix attached; with this applied, I can get a successful Poudriere run.
Comment 1 Ed Maste freebsd_committer 2017-08-09 13:22:46 UTC
*** Bug 220856 has been marked as a duplicate of this bug. ***
Comment 2 commit-hook freebsd_committer 2017-08-09 20:53:01 UTC
A commit references this bug:

Author: peter
Date: Wed Aug  9 20:52:09 UTC 2017
New revision: 447656
URL: https://svnweb.freebsd.org/changeset/ports/447656

Log:
  Fix broken build since r441842 (May 27, 2017). Add missing %%HTMLDOCS%%
  tag to webpage-17.html plist entry.

  PR:		220196, 220856

Changes:
  head/textproc/groff/pkg-plist