Bug 220232 - Upgrade math/clp to version 1.17.3 -rework OPTIONS while here.
Summary: Upgrade math/clp to version 1.17.3 -rework OPTIONS while here.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-06-23 20:55 UTC by Pedro F. Giffuni
Modified: 2019-12-21 22:55 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (co9co9)


Attachments
update diff (3.01 KB, patch)
2017-06-23 20:55 UTC, Pedro F. Giffuni
no flags Details | Diff
update diff (2.90 KB, patch)
2017-06-23 20:59 UTC, Pedro F. Giffuni
no flags Details | Diff
1.16.11 update diff (3.15 KB, patch)
2017-09-17 22:44 UTC, Pedro F. Giffuni
no flags Details | Diff
Update to version 1.17.3 (12.45 KB, patch)
2019-08-09 17:02 UTC, Pedro F. Giffuni
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro F. Giffuni freebsd_committer 2017-06-23 20:55:57 UTC
Created attachment 183748 [details]
update diff

Minor update.
Make Fortran and GLPK options. Set them OFF by default.

I would like to consider in the future making more Coin OR ports that reuse the headers from clp. I think Gentoo does it already but I haven't looked at the details.
Comment 1 Pedro F. Giffuni freebsd_committer 2017-06-23 20:59:15 UTC
Created attachment 183749 [details]
update diff

Reduce some difference. I can't really test the powerpc64 build :(.
Comment 2 Pedro F. Giffuni freebsd_committer 2017-09-17 22:44:20 UTC
Created attachment 186492 [details]
1.16.11 update diff

Update.
Comment 3 Pedro F. Giffuni freebsd_committer 2018-02-28 15:34:31 UTC
I have ported Cbc now, which carries clp and includes more functionality.
I think we should deprecate clp in favor of Cbc.
Comment 4 Walter Schwarzenfeld freebsd_triage 2019-08-09 09:06:36 UTC
ping!
Comment 5 Pedro F. Giffuni freebsd_committer 2019-08-09 17:02:24 UTC
Created attachment 206401 [details]
Update to version 1.17.3

Upstream carries the fixes.
Turn off MUMPS for now since its broken.
Comment 6 Pedro F. Giffuni freebsd_committer 2019-12-21 20:24:46 UTC
Maintainer timeout?
Comment 7 Yuri Victorovich freebsd_committer 2019-12-21 20:43:32 UTC
yes, will commit once confirmed working.
Comment 8 Yuri Victorovich freebsd_committer 2019-12-21 22:55:44 UTC
Committed.
Comment 9 commit-hook freebsd_committer 2019-12-21 22:55:47 UTC
A commit references this bug:

Author: yuri
Date: Sat Dec 21 22:55:32 UTC 2019
New revision: 520583
URL: https://svnweb.freebsd.org/changeset/ports/520583

Log:
  math/clp: Update 1.16.10 -> 1.17.3

  PR:		220232
  Submitted by:	pfg
  Approved by:	co9co9@gmail.com (maintainer's timeout; 2+ years)

Changes:
  head/math/clp/Makefile
  head/math/clp/distinfo
  head/math/clp/files/patch-Clp_src_AbcSimplex.cpp
  head/math/clp/files/patch-Clp_src_ClpModel.cpp
  head/math/clp/files/patch-Clp_src_OsiClp_OsiClpSolverInterface.cpp
  head/math/clp/pkg-plist