Bug 220343 - The manual page for mpt(4) should inform about disk size limitations of most/all supported controllers
Summary: The manual page for mpt(4) should inform about disk size limitations of most/...
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Daniel Ebdrup Jensen
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-06-28 19:01 UTC by Sebastian Oswald (sko)
Modified: 2021-01-17 01:02 UTC (History)
2 users (show)

See Also:


Attachments
patch for the mpt manpage, adding warning about disk size limitations (826 bytes, patch)
2017-07-14 13:41 UTC, Sebastian Oswald (sko)
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Oswald (sko) 2017-06-28 19:01:26 UTC
Most (if not all?) controllers supported by the mpt driver have firmware- and/or hardware-induced limitations on their supported disk/array/LUN size -  mostly <2TB. As these limitations are well below typical sizes of modern hard drives, it would be sensible to inform the user about these limitations in the manual page.


While most controllers truncate the usable/reported size to the supported size, some might wrap around and cause serious data corruption. See for example the 3ware 7000/8000 series in this archived KB article: http://web.archive.org/web/20120326110817/http://kb.lsi.com:80/KnowledgebaseArticle16481.aspx

From my own experiences, behaviour of many controllers with such limitations upon attaching bigger disks is best described as "undefined" - I've seen anything from not recognizing/reporting the disks, locking up at boot to severe data loss when reaching the supported size limit.

Due to the possibility of data loss on controllers that wrap around address space, I suggest adding the information about these limitations and possible data loss within a WARNING section of the manual page.


Draft/suggestion:

----

WARNING

Most controllers supported by the mpt driver suffer from limitations on supported disk size (mostly <2TB). While *most* controllers will only truncate usable disk size, others might behave unexpectedly and cause severe data loss. Refer to the specifications of your chipset and firmware version for information about supported disk size.

----


-- 
Regards,
Sebastian
Comment 1 Sebastian Oswald (sko) 2017-07-14 13:41:29 UTC
Created attachment 184353 [details]
patch for the mpt manpage, adding warning about disk size limitations
Comment 2 Daniel Ebdrup Jensen freebsd_committer 2021-01-16 22:48:13 UTC
It's a little late, but I'll take this.

Incidentally, is it okay to credit you as "Sebastian Oswald <sebastian at rostwald.de>" in the commit?
Comment 3 commit-hook freebsd_committer 2021-01-16 23:44:00 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/src/commit/?id=0ec6c03c76821edacba0615d3883293ad5f37dfc

commit 0ec6c03c76821edacba0615d3883293ad5f37dfc
Author:     Sebastian Oswald <sebastian at rostwald.de>
AuthorDate: 2021-01-16 23:27:43 +0000
Commit:     Daniel Ebdrup Jensen <debdrup@FreeBSD.org>
CommitDate: 2021-01-16 23:41:59 +0000

    mpt.4: Warn about unexpected behaviour on older controllers

    Older controllers have errata which causes the disk controller to wrap
    data to other LBAs, causing data to be overwritten. [1]

    While here, fix a small typo.

    1: https://www.broadcom.com/support/knowledgebase/1211161496563/3-terabyte-3tb-capacity-drives-on-lsi-megaraid-and-3ware-control

    PR: 220343
    Submitted by:   Sebastian Oswald <sebastian at rostwald.de>
    Reviewed by:    0mp
    Event:          January 2021 Bugathon
    Differential Revision:  <https://reviews.freebsd.org/D28201

 share/man/man4/mpt.4 | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)
Comment 4 Daniel Ebdrup Jensen freebsd_committer 2021-01-16 23:45:08 UTC
Thank you for your attention to detail. :)
Comment 5 Sebastian Oswald (sko) 2021-01-17 01:02:36 UTC
(In reply to Daniel Ebdrup Jensen from comment #2)

Better late than never ;)

> Incidentally, is it okay to credit you as "Sebastian Oswald <sebastian at
> rostwald.de>" in the commit?
Yes, that's ok, thanks!