Bug 220399 - Handbook java browser plugin instructions are no longer applicable
Summary: Handbook java browser plugin instructions are no longer applicable
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Eitan Adler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-30 22:01 UTC by Randy Westlund
Modified: 2018-01-01 10:07 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Randy Westlund 2017-06-30 22:01:29 UTC
https://www.freebsd.org/doc/handbook/desktop-browsers.html

Handbook section 6.2 Browsers contains a few sections about how to setup Java and other plugins in various browsers.

Firefox and Chromium (among others) no longer support NPAPI plugins like Java, so these instructions are no longer valid.

I think you can still use the icedtea-web package to run downloaded Java Web Start applications manually, which should be explained in this section.
Comment 1 commit-hook freebsd_committer 2018-01-01 10:07:55 UTC
A commit references this bug:

Author: eadler
Date: Mon Jan  1 10:07:34 UTC 2018
New revision: 51357
URL: https://svnweb.freebsd.org/changeset/doc/51357

Log:
  handbook: remove instructions for NPAPI plugins

  - Neither Firefox nor Chrome support NPAPI plugins anymore and as such
    the instructions to install them are not applicable.
  - Tell users of opera to install the plugin directly rather than
    redirect to Firefox's instructions. I have not validated that this
    still works. Google shows mixed information for Opera's NPAPI support.
  - While here remove an extraneous word 'new'

  PR:		220399
  Reported by:	Randy Westlund <rwestlun@gmail.com>

Changes:
  head/en_US.ISO8859-1/books/handbook/desktop/chapter.xml