Bug 220502 - lib.libc.stdio.printf_test.snprintf_float segfaults
Summary: lib.libc.stdio.printf_test.snprintf_float segfaults
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: tests (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-testing (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-06 07:43 UTC by Enji Cooper
Modified: 2018-03-05 19:05 UTC (History)
3 users (show)

See Also:
asomers: mfc-stable11+
asomers: mfc-stable10+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2017-07-06 07:43:14 UTC
This started happening in the last month or so:
https://ci.freebsd.org/job/FreeBSD-head-amd64-test/3387/testReport/lib.libc.stdio/printf_test/snprintf_float/
Comment 1 commit-hook freebsd_committer 2017-07-06 07:46:22 UTC
A commit references this bug:

Author: ngie
Date: Thu Jul  6 07:45:20 UTC 2017
New revision: 320726
URL: https://svnweb.freebsd.org/changeset/base/320726

Log:
  Expect :snprintf_float to segfault

  This issue started occurring within the past month or so.

  PR:	220502
  Reported by:	Jenkins (amd64-head job)

Changes:
  head/contrib/netbsd-tests/lib/libc/stdio/t_printf.c
Comment 2 commit-hook freebsd_committer 2017-07-06 07:59:34 UTC
A commit references this bug:

Author: ngie
Date: Thu Jul  6 07:59:01 UTC 2017
New revision: 320727
URL: https://svnweb.freebsd.org/changeset/base/320727

Log:
  :snprintf_float: don't blindly set RLIMIT_DATA and RLIMIT_AS to 1 MB -- raise
  the limit to 32MB instead.

  Require user=root and memory=64MB+ first so one can be reasonably sure that
  the test will function appropriately.

  MFC after:	1 month
  MFC with:	r320726
  PR:	220502

Changes:
  head/contrib/netbsd-tests/lib/libc/stdio/t_printf.c
Comment 3 Enji Cooper freebsd_committer 2017-07-06 08:12:10 UTC
I suspect the segfault was either happening due to the ino64 project's increased footprint requirement or the jemalloc upgrade. Nevertheless, the test should have been more robust.
Comment 4 Konstantin Belousov freebsd_committer 2017-07-06 09:08:41 UTC
(In reply to Ngie Cooper from comment #3)
So does the test pass now, with the resource limits increased ?  Or there is something further to look at ?
Comment 5 Eitan Adler freebsd_committer freebsd_triage 2018-01-08 04:14:47 UTC
For the following conditions
Product: Base System, Documentation Status: New, Open, In Progress, UNCONFIRMED 
Assignee: Former FreeBSD committer 

Reset to default assignee. Reset status to "Open".
Comment 6 commit-hook freebsd_committer 2018-03-05 18:37:51 UTC
A commit references this bug:

Author: asomers
Date: Mon Mar  5 18:37:05 UTC 2018
New revision: 330519
URL: https://svnweb.freebsd.org/changeset/base/330519

Log:
  MFC r320726, r320727

  r320726:
  Expect :snprintf_float to segfault

  This issue started occurring within the past month or so.

  PR:   220502
  Reported by:  Jenkins (amd64-head job)

  r320727:
  :snprintf_float: don't blindly set RLIMIT_DATA and RLIMIT_AS to 1 MB -- raise
  the limit to 32MB instead.

  Require user=root and memory=64MB+ first so one can be reasonably sure that
  the test will function appropriately.

  MFC with:	r320726
  PR:	220502

Changes:
_U  stable/11/
  stable/11/contrib/netbsd-tests/lib/libc/stdio/t_printf.c
Comment 7 commit-hook freebsd_committer 2018-03-05 18:37:53 UTC
A commit references this bug:

Author: asomers
Date: Mon Mar  5 18:37:05 UTC 2018
New revision: 330519
URL: https://svnweb.freebsd.org/changeset/base/330519

Log:
  MFC r320726, r320727

  r320726:
  Expect :snprintf_float to segfault

  This issue started occurring within the past month or so.

  PR:   220502
  Reported by:  Jenkins (amd64-head job)

  r320727:
  :snprintf_float: don't blindly set RLIMIT_DATA and RLIMIT_AS to 1 MB -- raise
  the limit to 32MB instead.

  Require user=root and memory=64MB+ first so one can be reasonably sure that
  the test will function appropriately.

  MFC with:	r320726
  PR:	220502

Changes:
_U  stable/11/
  stable/11/contrib/netbsd-tests/lib/libc/stdio/t_printf.c
Comment 8 commit-hook freebsd_committer 2018-03-05 19:03:16 UTC
A commit references this bug:

Author: asomers
Date: Mon Mar  5 19:02:32 UTC 2018
New revision: 330520
URL: https://svnweb.freebsd.org/changeset/base/330520

Log:
  MFC r320726, r320727

  r320726:
  Expect :snprintf_float to segfault

  This issue started occurring within the past month or so.

  PR:   220502
  Reported by:  Jenkins (amd64-head job)

  r320727:
  :snprintf_float: don't blindly set RLIMIT_DATA and RLIMIT_AS to 1 MB -- raise
  the limit to 32MB instead.

  Require user=root and memory=64MB+ first so one can be reasonably sure that
  the test will function appropriately.

  MFC with:     r320726
  PR:   220502

Changes:
_U  stable/10/
  stable/10/contrib/netbsd-tests/lib/libc/stdio/t_printf.c
Comment 9 commit-hook freebsd_committer 2018-03-05 19:03:19 UTC
A commit references this bug:

Author: asomers
Date: Mon Mar  5 19:02:32 UTC 2018
New revision: 330520
URL: https://svnweb.freebsd.org/changeset/base/330520

Log:
  MFC r320726, r320727

  r320726:
  Expect :snprintf_float to segfault

  This issue started occurring within the past month or so.

  PR:   220502
  Reported by:  Jenkins (amd64-head job)

  r320727:
  :snprintf_float: don't blindly set RLIMIT_DATA and RLIMIT_AS to 1 MB -- raise
  the limit to 32MB instead.

  Require user=root and memory=64MB+ first so one can be reasonably sure that
  the test will function appropriately.

  MFC with:     r320726
  PR:   220502

Changes:
_U  stable/10/
  stable/10/contrib/netbsd-tests/lib/libc/stdio/t_printf.c