Created attachment 184143 [details]
patch for create new port
This is an alternative port of SQLite based on the creation of the source code.
This allows you to use more compilation options, extension modules and test the created libraries.
This solves the problem with PR#207383.
I hope in the future this port will be used instead of existing databases/sqlite3 and databases/tcl-sqlite3.
Created attachment 184144 [details]
It is not necessary to set the maintainer-approval flag for a new port. This is intended for the reply of an existing maintainer of an existing port.
(In reply to Mark Linimon from comment #2)
I'm sorry. I will take into account in the future. Thanks.
Created attachment 185807 [details]
[new] patch for create new port
New patch for new, SQLite 3.20.1 version.
Created attachment 185808 [details]
Created attachment 188878 [details]
[new] patch for create port with SQLite version 3.21
Created attachment 188879 [details]
There is newer version out, if you still plan to get this in ports
Created attachment 196673 [details]
[new] patch for create port with SQLite version 3.24
Created attachment 196674 [details]
Created attachment 196675 [details]
Don’t leave comments that doesn’t atleast explain something like:
# Length | | Length | OPTIONS_SUB= yes
OPTIONS_DEFAULT= # Clean default options # ===> OPTIONS_DEFINE
#OPTIONS_DEFINE= # portlint, for what?
Combine options_define for example:
OPTIONS_DEFINE= EXTENSIONS JSON
Don’t need += in options_define if you just do it together
Makes the makefile cleaner and easier to read
(In reply to Nathan from comment #12)
Leave in options_sub=yes
Change switches that use —-enable to be like
As an example
It’s safer to make sure enable/disable works
On switches usually need an off switch to make sure things are enabled or disabled.
Also combine the defining of options to one line:
OPTIONS_DEFINE= EXAMPLES JSON1 ANOTHER MORE ETC
Also remove unneeded comments like #DEFINE_OPTIONS= portlint for what